summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2020-02-08 15:36:37 +0100
committerJoan Figueras2020-02-08 15:36:37 +0100
commit787774547b90abcc4468f7928984571c3e0ce0b2 (patch)
treed355fae2fdf393f31bce93da9a2be3b0802f439e
parentae489b4fe649618554c0da515df9507895569114 (diff)
downloadaur-787774547b90abcc4468f7928984571c3e0ce0b2.tar.gz
5.4.17-rt9-xanmod
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
2 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 614bbbe3c04e..2a63578abfa9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-xanmod-rt
pkgdesc = Linux Xanmod real-time version
- pkgver = 5.4.10
+ pkgver = 5.4.17
pkgrel = 1
url = http://www.xanmod.org/
arch = x86_64
@@ -17,17 +17,18 @@ pkgbase = linux-xanmod-rt
makedepends = imagemagick
makedepends = cpio
options = !strip
- source = https://github.com/xanmod/linux/archive/5.4.10-rt5-xanmod.tar.gz
+ source = https://github.com/xanmod/linux/archive/5.4.17-rt9-xanmod.tar.gz
source = choose-gcc-optimization.sh
- sha256sums = 2e7f074bc7e54fed25c25097523079ae314cd599f5df8f66a8f4d3afd35f9ecf
+ source = 0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-CLONE_NEWUSER.patch::https://aur.archlinux.org/cgit/aur.git/plain/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch?h=linux-ck&id=616ec1bb1f2c0fc42b6fb5c20995996897b4f43b
+ sha256sums = 5b7591a7a8b0f453ffa4e4077b09bc7d423059a0496e6f3985456b908ace6fef
sha256sums = 8b2629f6340d4807c113cd9fa308f50f0a8d85df5698bef083e151f06d58f748
+ sha256sums = 9c507bdb0062b5b54c6969f7da9ec18b259e06cd26dbe900cfe79a7ffb2713ee
pkgname = linux-xanmod-rt
pkgdesc = The Linux kernel and modules with Xanmod patches
depends = coreutils
- depends = linux-firmware
depends = kmod
- depends = mkinitcpio
+ depends = initramfs
optdepends = crda: to set the correct wireless channels of your country
optdepends = linux-firmware: firmware images needed for some devices
diff --git a/PKGBUILD b/PKGBUILD
index 74c2c5cc2a19..89342e58bbbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -50,8 +50,8 @@ fi
##
pkgbase=linux-xanmod-rt
-pkgver=5.4.10
-xanmod=5
+pkgver=5.4.17
+xanmod=9
pkgrel=1
_rev=
pkgdesc='Linux Xanmod real-time version'
@@ -67,10 +67,12 @@ _srcname="linux-${pkgver}-rt${xanmod}-xanmod${_rev}"
source=(https://github.com/xanmod/linux/archive/${pkgver}-rt${xanmod}-xanmod${_rev}.tar.gz
choose-gcc-optimization.sh
+ '0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-CLONE_NEWUSER.patch::https://aur.archlinux.org/cgit/aur.git/plain/0001-ZEN-Add-sysctl-and-CONFIG-to-disallow-unprivileged-C.patch?h=linux-ck&id=616ec1bb1f2c0fc42b6fb5c20995996897b4f43b'
)
-sha256sums=('2e7f074bc7e54fed25c25097523079ae314cd599f5df8f66a8f4d3afd35f9ecf'
- '8b2629f6340d4807c113cd9fa308f50f0a8d85df5698bef083e151f06d58f748')
+sha256sums=('5b7591a7a8b0f453ffa4e4077b09bc7d423059a0496e6f3985456b908ace6fef'
+ '8b2629f6340d4807c113cd9fa308f50f0a8d85df5698bef083e151f06d58f748'
+ '9c507bdb0062b5b54c6969f7da9ec18b259e06cd26dbe900cfe79a7ffb2713ee')
export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
@@ -123,6 +125,11 @@ prepare() {
scripts/config --disable CONFIG_USER_NS_UNPRIVILEGED
fi
+ if [ "$use_ns" = "n" ]; then
+ msg2 "Disabling CONFIG_USER_NS_UNPRIVILEGED"
+ scripts/config --disable CONFIG_USER_NS_UNPRIVILEGED
+ fi
+
# Let's user choose microarchitecture optimization in GCC
sh ${srcdir}/choose-gcc-optimization.sh $_microarchitecture
@@ -146,7 +153,7 @@ build() {
_package() {
pkgdesc="The Linux kernel and modules with Xanmod patches"
- depends=(coreutils linux-firmware kmod mkinitcpio)
+ depends=(coreutils kmod initramfs)
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')