summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2021-03-02 23:59:02 +0100
committerJoan Figueras2021-03-02 23:59:02 +0100
commitd6e4a21e96feb0f7d85d89e42de3670e4b308160 (patch)
tree50288e2918dd0b92286e11ee656fc74ffa82a249
parent9f0fdf6cac5084ae31c16db34c4ecf91cbbea228 (diff)
downloadaur-d6e4a21e96feb0f7d85d89e42de3670e4b308160.tar.gz
Merged Arch PKGBUILD changes
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 121f832c7980..9ec2ad27f667 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -32,5 +32,6 @@ pkgname = linux-xanmod-rt
optdepends = linux-firmware: firmware images needed for some devices
pkgname = linux-xanmod-rt-headers
- pkgdesc = Header files and scripts for building modules for Xanmod Linux kernel
+ pkgdesc = Headers and scripts for building modules for the Linux Xanmod real-time version kernel
+ depends = pahole
diff --git a/PKGBUILD b/PKGBUILD
index 0f5424e74b2b..293b4a0ed6e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -200,14 +200,15 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
msg2 "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
+ make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 modules_install
# remove build and source links
rm "$modulesdir"/{source,build}
}
_package-headers() {
- pkgdesc="Header files and scripts for building modules for Xanmod Linux kernel"
+ pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
+ depends=(pahole)
cd linux-${_major}
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
@@ -276,6 +277,8 @@ _package-headers() {
esac
done < <(find "$builddir" -type f -perm -u+x ! -name vmlinux -print0)
+ msg2 "Stripping vmlinux..."
+ strip -v $STRIP_STATIC "$builddir/vmlinux"
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/src"
ln -sr "$builddir" "$pkgdir/usr/src/$pkgbase"