summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2022-01-29 00:13:24 +0100
committerJoan Figueras2022-01-29 00:13:24 +0100
commit0a9f5df7a9b2c71d2b2e0f1a71e0232d1e6b3444 (patch)
tree620e6ef53be86aaba65e9d288237ff494d95932b
parent49d9c8fc36b8d36707edff482195cdf13460da44 (diff)
downloadaur-0a9f5df7a9b2.tar.gz
Convert _makenconfig as external variable, as requested by Gobidev
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7256064f3d64..5de7c55773fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -54,7 +54,9 @@ if [ -z ${_localmodcfg} ]; then
fi
# Tweak kernel options prior to a build via nconfig
-_makenconfig=
+if [ -z ${_makenconfig} ]; then
+ _makenconfig=n
+fi
### IMPORTANT: Do no edit below this line unless you know what you're doing
@@ -199,7 +201,9 @@ prepare() {
make -s kernelrelease > version
msg2 "Prepared %s version %s" "$pkgbase" "$(<version)"
- [[ -z "$_makenconfig" ]] || make LLVM=$_LLVM LLVM_IAS=$_LLVM nconfig
+ if [ "$_makenconfig" = "y" ]; then
+ make LLVM=$_LLVM LLVM_IAS=$_LLVM nconfig
+ fi
# save configuration for later reuse
cat .config > "${SRCDEST}/config.last"