summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2022-01-28 00:14:33 +0100
committerJoan Figueras2022-01-28 00:14:33 +0100
commit8339781d3b46f25c827b1fb03f1ff35ade2efb05 (patch)
tree633a43d3a022f714eba79c1e57a1e4b5be7a8f05
parenta4ea604a3c9f47264fec91e416097b24aad480b2 (diff)
downloadaur-8339781d3b46f25c827b1fb03f1ff35ade2efb05.tar.gz
Workaround for #240
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3dca5cd48f2c..776e9707f1f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -161,6 +161,9 @@ prepare() {
# Let's user choose microarchitecture optimization in GCC
sh ${srcdir}/choose-gcc-optimization.sh $_microarchitecture
+ # Disable CONFIG_GENERIC_CPU2 if we have choosen another microarchitecture
+ # https://github.com/xanmod/linux/issues/240
+ [ "$_microarchitecture" = "0" ] || scripts/config --disable CONFIG_GENERIC_CPU2
# This is intended for the people that want to build this package with their own config
# Put the file "myconfig" at the package folder (this will take preference) or "${XDG_CONFIG_HOME}/linux-xanmod/myconfig"