summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhullyb2021-04-09 21:15:28 +0800
committerzhullyb2021-04-09 21:15:28 +0800
commit58377a692c2b8c34659c025280562283043927b7 (patch)
treee6fe68511f5d1f0736e81f5dd62f97ea3de501c6
parentd5c3e849c898bc627941d5000ff70023aaa17e7e (diff)
downloadaur-58377a692c2b8c34659c025280562283043927b7.tar.gz
Fix
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1884ed484c8f..a5345734114d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,7 +14,7 @@ pkgbase = linux-xanmod-cacule-uksm-cjktty
options = !strip
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.11.tar.xz
source = https://cdn.kernel.org/pub/linux/kernel/v5.x/linux-5.11.tar.sign
- source = https://github.com/xanmod/linux/releases/download/5.11.12-xanmod1-cacule/patch-5.11.12-xanmod1-cacule.xz
+ source = https://github.com/HougeLangley/customkernel/releases/download/Kernel-v5.11.x/patch-5.11.12-xanmod1-cacule
source = choose-gcc-optimization.sh
source = sphinx-workaround.patch
source = 0002-UKSM.patch
diff --git a/PKGBUILD b/PKGBUILD
index 765b43ecfb41..72d9c3293ddd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,4 @@
-# Maintainer: zhullyb <zhullyb@outlook.com>
-# Contributor: Yeqin Su <hougelangley1987@gmail.com>
+# Maintainer: Yeqin Su <hougelangley1987@gmail.com>
# Contributor: Torge Matthies <openglfreak at googlemail dot com>
# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Yoshi2889 <rick.2889 at gmail dot com>
@@ -17,6 +16,7 @@
## Valid numbers between: 0 to 42
## Default is: 0 => generic
## Good option if your package is for one machine: 42 => native
+## 我个人的恶趣味,就是选择 native,自动优化,当然各位根据自己的实际情况做出选择也是可以的
if [ -z ${_microarchitecture+x} ]; then
_microarchitecture=0
fi
@@ -54,6 +54,7 @@ if [ -z ${_localmodcfg} ]; then
fi
# Tweak kernel options prior to a build via nconfig
+# 我觉得还是选上,这样给大家微调的空间
#_makenconfig=y
### IMPORTANT: Do no edit below this line unless you know what you're doing
@@ -76,11 +77,11 @@ options=('!strip')
_srcname="linux-${pkgver}-xanmod${xanmod}"
source=("https://cdn.kernel.org/pub/linux/kernel/v${_branch}/linux-${_major}.tar."{xz,sign}
- "https://github.com/xanmod/linux/releases/download/${pkgver}-xanmod${xanmod}-cacule/patch-${pkgver}-xanmod${xanmod}-cacule.xz"
+ "https://github.com/HougeLangley/customkernel/releases/download/Kernel-v5.11.x/patch-5.11.12-xanmod1-cacule"
choose-gcc-optimization.sh
'sphinx-workaround.patch'
'0002-UKSM.patch'
- "0003-CJKTTY.patch::https://raw.githubusercontent.com/zhmars/cjktty-patches/master/v5.x/cjktty-${_major}.patch")
+ '0003-CJKTTY.patch::https://raw.githubusercontent.com/zhmars/cjktty-patches/master/v5.x/cjktty-5.11.patch')
validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linux Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
@@ -108,8 +109,7 @@ prepare() {
cd linux-${_major}
# Apply Xanmod patch
-
- xz -d < patch-${pkgver}-xanmod${xanmod}-cacule.xz | patch -Np1
+ patch -Np1 -i ../patch-${pkgver}-xanmod${xanmod}-cacule
msg2 "Setting version..."
scripts/setlocalversion --save-scmversion