summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorantman6662023-04-30 00:16:19 +0800
committerantman6662023-04-30 00:16:19 +0800
commit8a9d6137f999877dc7bc9ad681f2d5a833b54c87 (patch)
treee3c2d5616f60acbe86ed55d1ab623cd91b5ec7a8
parent2cb37049bf1064aa6af7590b8b3839d48af7106e (diff)
downloadaur-8a9d6137f999877dc7bc9ad681f2d5a833b54c87.tar.gz
update linux-xanmod-tt-uksm-cjktty to 6.3.0-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD11
-rw-r--r--kernel.install17
3 files changed, 30 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b9383d69c85..29f3df8a9911 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = linux-xanmod-tt-uksm-cjktty
pkgdesc = Linux Xanmod. Development branch with the Task Type CPU Scheduler by Hamad Al Marri
- pkgver = 6.1.8
+ pkgver = 6.3.0
pkgrel = 1
url = http://www.xanmod.org/
arch = x86_64
@@ -18,12 +18,12 @@ pkgbase = linux-xanmod-tt-uksm-cjktty
makedepends = python
depends = uksmd
options = !strip
- source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.1.tar.xz
- source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.1.tar.sign
- source = https://github.com/antman666/linux-xanmod-tt-uksm-cjktty/releases/download/linux-xanmod-tt-uksm-cjktty_v6.1.8/patch-6.1.8-xanmod1-tt.zst
+ source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.3.tar.xz
+ source = https://cdn.kernel.org/pub/linux/kernel/v6.x/linux-6.3.tar.sign
+ source = https://github.com/antman666/linux-xanmod-tt-uksm-cjktty/releases/download/linux-xanmod-tt-uksm-cjktty_v6.3.0/patch-6.3.0-xanmod1-tt.zst
source = choose-gcc-optimization.sh
- source = 0001-cjktty.patch::https://raw.githubusercontent.com/zhmars/cjktty-patches/master/v6.x/cjktty-6.1.patch
- source = 0002-UKSM.patch::https://raw.githubusercontent.com/sirlucjan/kernel-patches/master/6.1/uksmd-cachyos-patches-all/0001-uksmd-cachyos-patches.patch
+ source = 0001-cjktty.patch::https://raw.githubusercontent.com/zhmars/cjktty-patches/master/v6.x/cjktty-6.3.patch
+ source = 0002-UKSM.patch::https://raw.githubusercontent.com/sirlucjan/kernel-patches/master/6.3/uksmd-cachyos-patches-all/0001-uksmd-cachyos-patches.patch
validpgpkeys = ABAF11C65A2970B130ABE3C479BE3E4300411886
validpgpkeys = 647F28654894E3BD457199BE38DBBDC86092693E
sha256sums = 2ca1f17051a430f6fed1196e4952717507171acfd97d96577212502703b25deb
@@ -34,7 +34,8 @@ pkgbase = linux-xanmod-tt-uksm-cjktty
sha256sums = 1e88663a54843a747d717ea6f2fc5d1233056c30433e1b685d09cae9921a2cff
pkgname = linux-xanmod-tt-uksm-cjktty
- pkgdesc = The Linux kernel and modules with Xanmod patches
+ pkgdesc = The Linux kernel and modules with Xanmod, TaskType, cjktty etc. patches
+ install = kernel.install
depends = coreutils
depends = kmod
depends = initramfs
diff --git a/PKGBUILD b/PKGBUILD
index aeea4637effd..53d790b6eb83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer : AntMan666 <945360554@qq.com>
+# Maintainer : AntMan666 <antman666@qq.com>
# Contributor: zhullyb <zhullyb@outlook.com>
# Contributor: Yeqin Su <hougelangley1987@gmail.com>
# Contributor: Joan Figueras <ffigue at gmail dot com>
@@ -101,8 +101,8 @@ fi
### IMPORTANT: Do no edit below this line unless you know what you're doing
pkgbase=linux-xanmod-tt-uksm-cjktty
-_major=6.1
-pkgver=${_major}.8
+_major=6.3
+pkgver=${_major}.0
_branch=6.x
xanmod=1
pkgrel=${xanmod}
@@ -161,7 +161,6 @@ prepare() {
patch -Np1 -i ../patch-${pkgver}-xanmod${xanmod}-tt
msg2 "Setting version..."
- scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux-xanmod}" > localversion.20-pkgname
@@ -378,7 +377,6 @@ prepare() {
fi
fi
- scripts/config --disable CONFIG_X86_X32
scripts/config --disable CONFIG_STACKPROTECTOR_STRONG
scripts/config --enable CONFIG_WINESYNC
@@ -437,7 +435,7 @@ build() {
}
_package() {
- pkgdesc="The Linux kernel and modules with Xanmod patches"
+ pkgdesc="The Linux kernel and modules with Xanmod, TaskType, cjktty etc. patches"
depends=(coreutils kmod initramfs)
optdepends=('crda: to set the correct wireless channels of your country'
'linux-firmware: firmware images needed for some devices')
@@ -445,6 +443,7 @@ _package() {
WIREGUARD-MODULE
KSMBD-MODULE
NTFS3-MODULE)
+ install=kernel.install
cd linux-${_major}
local kernver="$(<version)"
diff --git a/kernel.install b/kernel.install
new file mode 100644
index 000000000000..32c58bfebc42
--- /dev/null
+++ b/kernel.install
@@ -0,0 +1,17 @@
+#!/bin/bash
+
+post_install() {
+ if [ $(nproc --all) -lt 4 ]; then
+ echo "I noticed that your CPU core(s) is(are) less than or equal 4, so it's good to set kernel.sched_tt_balancer_opt=1"
+ else
+ echo "I noticed that your CPU cores are more than 4, so it's good to set kernel.sched_tt_balancer_opt=0"
+ fi
+}
+
+post_upgrade() {
+ if [ $(nproc --all) -lt 4 ]; then
+ echo "I noticed that your CPU core(s) is(are) less than or equal 4, so it's good to set kernel.sched_tt_balancer_opt=1"
+ else
+ echo "I noticed that your CPU cores are more than 4, so it's good to set kernel.sched_tt_balancer_opt=0"
+ fi
+}