summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle De'Vir2018-11-24 09:11:26 +1000
committerKyle De'Vir2018-11-24 09:11:26 +1000
commit1cf95977a3a0cde70433825630b5a3f5d96e9fca (patch)
treedadc0df2622b2d034f1ea65434dbbaa43fa2dee6
parentaaa09f3feee3ca68899f19467e812953e3de8b2b (diff)
downloadaur-1cf95977a3a0cde70433825630b5a3f5d96e9fca.tar.gz
Change to using v4.19.4 tag for zen-kernel
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5503a711497c..15d3894c1eb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-zen-bcachefs-git
- pkgver = 4.19.4
+ pkgver = 4.19.4.zen1
pkgrel = 1
url = https://evilpiepirate.org/git/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 964b15a55532..3799879e7296 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,15 @@
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Thomas Baechler <thomas@archlinux.org>
+### BUILD OPTIONS
+# Set these variables to ANYTHING that is not null to enable them
+
+# Tweak kernel options prior to a build via nconfig
+_makenconfig=
+
pkgbase=linux-zen-bcachefs-git
-pkgver=4.19.4
+_srcver=4.19.4-zen1
+pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
url="https://evilpiepirate.org/git/"
@@ -37,7 +44,7 @@ prepare() {
msg2 "Adding patches from zen-kernel repository..."
git remote add upstream-zen https://github.com/zen-kernel/zen-kernel
- git pull upstream-zen 4.19/master
+ git pull upstream-zen v$_srcver
msg2 "Revert 4.19/muqss due to strange buggy interactions with bcachefs..."
git revert -m 1 9731135d7610a36bbe4cce0dbcd0d942e7436e94
@@ -63,7 +70,7 @@ prepare() {
make -s kernelrelease > ../version
msg2 "Prepared %s version %s" "$pkgbase" "$(<../version)"
- make nconfig
+ [[ -z "$_makenconfig" ]] || make nconfig
# save configuration for later reuse
cat .config > "${startdir}/config.last"