summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle De'Vir2018-12-01 13:48:26 +1000
committerKyle De'Vir2018-12-01 13:48:26 +1000
commit664354b7256f813f7b1662c6982521a3c6182ccf (patch)
treec826d649cae8e4f65df9ddef3db82b2c11042577
parentbbd277c436e197868d7492ed124aaaa5d1c8c7e4 (diff)
downloadaur-664354b7256f813f7b1662c6982521a3c6182ccf.tar.gz
4.19.5
-rw-r--r--.SRCINFO2
-rw-r--r--90-linux.hook2
-rw-r--r--PKGBUILD15
-rw-r--r--linux.install2
4 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8b4af3d2c60..77b065b121ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = linux-zen-bcachefs-git
- pkgver = 4.19.4.zen1
+ pkgver = 4.19.5.zen1
pkgrel = 1
url = https://evilpiepirate.org/git/
arch = x86_64
diff --git a/90-linux.hook b/90-linux.hook
index be0d886539f4..fca45abe1a62 100644
--- a/90-linux.hook
+++ b/90-linux.hook
@@ -2,7 +2,7 @@
Type = File
Operation = Install
Operation = Upgrade
-Target = boot/vmlinuz-%PKGBASE%
+Target = usr/lib/modules/%KERNVER%/vmlinuz
Target = usr/lib/initcpio/*
[Action]
diff --git a/PKGBUILD b/PKGBUILD
index 705220e5171e..83087f5fd8a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,7 +26,7 @@ _makenconfig=
_localmodcfg=
pkgbase=linux-zen-bcachefs-git
-_srcver=4.19.4-zen1
+_srcver=4.19.5-zen1
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
@@ -119,22 +119,19 @@ _package() {
install=linux.install
local kernver="$(<version)"
+ local modulesdir="$pkgdir/usr/lib/modules/$kernver"
cd $_srcname
msg2 "Installing boot image..."
- local image="$pkgdir/boot/vmlinuz-$pkgbase"
- install -Dm644 "$(make -s image_name)" "$image"
+ # systemd expects to find the kernel here to allow hibernation
+ # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
+ install -Dm644 "$(make -s image_name)" "$modulesdir/vmlinuz"
+ install -Dm644 "$modulesdir/vmlinuz" "$pkgdir/boot/vmlinuz-$pkgbase"
msg2 "Installing modules..."
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
- mkdir -p "$modulesdir"
make INSTALL_MOD_PATH="$pkgdir/usr" modules_install
- # systemd expects to find the kernel here to allow hibernation
- # https://github.com/systemd/systemd/commit/edda44605f06a41fb86b7ab8128dcf99161d2344
- ln -sr "$image" "$modulesdir/vmlinuz"
-
# a place for external modules,
# with version file for building modules and running depmod from hook
local extramodules="extramodules$_kernelname"
diff --git a/linux.install b/linux.install
index 37ba37494605..43b8071cf8a4 100644
--- a/linux.install
+++ b/linux.install
@@ -8,3 +8,5 @@ post_remove() {
rm -f boot/initramfs-%PKGBASE%.img
rm -f boot/initramfs-%PKGBASE%-fallback.img
}
+
+# vim:set ft=sh ts=8 sts=2 sw=2 et: