summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle De'Vir2018-11-26 10:56:22 +1000
committerKyle De'Vir2018-11-26 10:56:22 +1000
commit773b5faa6ad6e10e9caecc0f7aa2d49879655f17 (patch)
tree552015e0f97287a4516fdd42acacae537cc8ea7b
parent9dba466cad37c01ea41e733d3680ddee5f1ab74c (diff)
downloadaur-773b5faa6ad6e10e9caecc0f7aa2d49879655f17.tar.gz
Restore bcachefs config support
-rw-r--r--PKGBUILD2
-rw-r--r--config11
2 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 00ae31a640f5..82736a71a354 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# Set these variables to ANYTHING that is not null to enable them
# Tweak kernel options prior to a build via nconfig
-_makenconfig=
+_makenconfig=y
# Compile ONLY probed modules
# As of mainline 2.6.32, running with this option will only build the modules
diff --git a/config b/config
index 16aede5a82ed..3187a9bfaaa0 100644
--- a/config
+++ b/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.19.3-zen1 Kernel Configuration
+# Linux/x86 4.19.4-zen1 Kernel Configuration
#
#
@@ -2704,7 +2704,6 @@ CONFIG_MD_FAULTY=m
CONFIG_MD_CLUSTER=m
CONFIG_BCACHE=m
# CONFIG_BCACHE_DEBUG is not set
-# CONFIG_BCACHE_CLOSURES_DEBUG is not set
CONFIG_BLK_DEV_DM_BUILTIN=y
CONFIG_BLK_DEV_DM=m
CONFIG_DM_MQ_DEFAULT=y
@@ -8863,6 +8862,11 @@ CONFIG_F2FS_CHECK_FS=y
CONFIG_F2FS_FS_ENCRYPTION=y
# CONFIG_F2FS_IO_TRACE is not set
# CONFIG_F2FS_FAULT_INJECTION is not set
+CONFIG_BCACHEFS_FS=m
+CONFIG_BCACHEFS_QUOTA=y
+CONFIG_BCACHEFS_POSIX_ACL=y
+# CONFIG_BCACHEFS_DEBUG is not set
+# CONFIG_BCACHEFS_TESTS is not set
CONFIG_FS_DAX=y
CONFIG_FS_DAX_PMD=y
CONFIG_FS_POSIX_ACL=y
@@ -9519,6 +9523,7 @@ CONFIG_BTREE=y
CONFIG_INTERVAL_TREE=y
CONFIG_RADIX_TREE_MULTIORDER=y
CONFIG_ASSOCIATIVE_ARRAY=y
+CONFIG_CLOSURES=y
CONFIG_HAS_IOMEM=y
CONFIG_HAS_IOPORT_MAP=y
CONFIG_HAS_DMA=y
@@ -9692,6 +9697,7 @@ CONFIG_DEBUG_BUGVERBOSE=y
CONFIG_RCU_CPU_STALL_TIMEOUT=60
# CONFIG_RCU_TRACE is not set
# CONFIG_RCU_EQS_DEBUG is not set
+# CONFIG_DEBUG_CLOSURES is not set
# CONFIG_DEBUG_WQ_FORCE_RR_CPU is not set
# CONFIG_DEBUG_BLOCK_EXT_DEVT is not set
# CONFIG_CPU_HOTPLUG_STATE_CONTROL is not set
@@ -9699,6 +9705,7 @@ CONFIG_RCU_CPU_STALL_TIMEOUT=60
CONFIG_FUNCTION_ERROR_INJECTION=y
# CONFIG_FAULT_INJECTION is not set
CONFIG_LATENCYTOP=y
+# CONFIG_DYNAMIC_FAULT is not set
CONFIG_USER_STACKTRACE_SUPPORT=y
CONFIG_NOP_TRACER=y
CONFIG_HAVE_FUNCTION_TRACER=y