summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle De'Vir2018-12-02 10:45:08 +1000
committerKyle De'Vir2018-12-02 10:45:08 +1000
commit90e5c44a03a85b280b778a9684068a29ea5c8b20 (patch)
tree8b901e69891c59b1941c6678a29a93c477c93604
parent5a4031b023fabea607943eefc592884f0b210dd8 (diff)
downloadaur-90e5c44a03a85b280b778a9684068a29ea5c8b20.tar.gz
localmodconfig changes
-rw-r--r--PKGBUILD24
1 files changed, 12 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 36d11f1f6867..1a6beae2086d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,9 +14,7 @@ _makenconfig=
# that you currently have probed in your system VASTLY reducing the number of
# modules built and the build time to do it.
#
-# WARNING - ALL modules must be probed or loaded via a config file BEFORE you
-# begin making the pkg unless you're running modprobed-db (AUR) and building
-# this with makepkg as the user who is keeping the database.
+# WARNING - ALL modules must be probed BEFORE you begin making the pkg!
#
# To keep track of which modules are needed for your specific system/hardware,
# give module_db script a try: https://aur.archlinux.org/packages/modprobed-db
@@ -84,17 +82,19 @@ prepare() {
### Optionally load needed modules for the make localmodconfig
# See https://aur.archlinux.org/packages/modprobed-db
- if [ -n "$_localmodcfg" ]; then
- if [ -f $HOME/.config/modprobed.db ]; then
- msg "Found a modprobed-db database for Steven Rostedt's make localmodconfig"
- make LSMOD=$HOME/.config/modprobed.db localmodconfig
- else
- msg "Running Steven Rostedt's make localmodconfig now"
- make localmodconfig
+ if [ -n "$_localmodcfg" ]; then
+ msg "If you have modprobed-db installed, running it in recall mode now"
+ if [ -e /usr/bin/modprobed-db ]; then
+ [[ -x /usr/bin/sudo ]] || {
+ echo "Cannot call modprobe with sudo. Install sudo and configure it to work with this user."
+ exit 1; }
+ sudo /usr/bin/modprobed-db recall
+ make localmodconfig
+ fi
fi
- fi
- make olddefconfig
+ # do not run `make olddefconfig` as it sets default options
+ yes "" | make config >/dev/null
make -s kernelrelease > ../version
msg2 "Prepared %s version %s" "$pkgbase" "$(<../version)"