summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShayne Hartford2019-04-20 21:26:08 -0400
committerShayne Hartford2019-04-20 21:26:08 -0400
commit83976c978a1107595803d9c2dcbd35ef68aa998f (patch)
treea6331d04eb5011a08fd9132e4a34a48b9c104d43
parent53faef76c4becc8e1030d1616db191a70e3b9e9f (diff)
downloadaur-83976c978a1107595803d9c2dcbd35ef68aa998f.tar.gz
Revert "FS#59688 - Install HTML docs"
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD21
2 files changed, 7 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be34993718b4..02331f45e340 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linux-zen-vfio
- pkgver = 5.0.7.zen1
+ pkgver = 5.0.8.zen1
pkgrel = 1
- url = https://github.com/zen-kernel/zen-kernel/commits/v5.0.7-zen1
+ url = https://github.com/zen-kernel/zen-kernel/commits/v5.0.8-zen1
arch = x86_64
license = GPL2
makedepends = xmlto
@@ -10,10 +10,8 @@ pkgbase = linux-zen-vfio
makedepends = bc
makedepends = libelf
makedepends = git
- makedepends = python-sphinx
- makedepends = graphviz
options = !strip
- source = zen-kernel::git+https://github.com/zen-kernel/zen-kernel?signed#tag=v5.0.7-zen1
+ source = zen-kernel::git+https://github.com/zen-kernel/zen-kernel?signed#tag=v5.0.8-zen1
source = config
source = 60-linux.hook
source = 90-linux.hook
diff --git a/PKGBUILD b/PKGBUILD
index 679c615d63e0..ec162bebbb91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,13 @@
# Maintainer: Shayne Hartford<shayneehartford@gmail.com>
-pkgbase=linux-zen-vfio # Build stock -zen kernel
-#pkgbase=linux-custom # Build kernel with a different name
-_srcver=5.0.7-zen1
+pkgbase=linux-zen-vfio
+_srcver=5.0.8-zen1
pkgver=${_srcver//-/.}
pkgrel=1
arch=(x86_64)
url="https://github.com/zen-kernel/zen-kernel/commits/v$_srcver"
license=(GPL2)
-makedepends=(xmlto kmod inetutils bc libelf git python-sphinx graphviz)
+makedepends=(xmlto kmod inetutils bc libelf git)
options=('!strip')
_srcname=zen-kernel
source=(
@@ -63,7 +62,7 @@ prepare() {
build() {
cd $_srcname
- make bzImage modules htmldocs
+ make bzImage modules
}
_package() {
@@ -214,18 +213,6 @@ _package-docs() {
mkdir -p "$builddir"
cp -t "$builddir" -a Documentation
- msg2 "Removing doctrees..."
- rm -r "$builddir/Documentation/output/.doctrees"
-
- msg2 "Moving HTML docs..."
- local src dst
- while read -rd '' src; do
- dst="$builddir/Documentation/${src#$builddir/Documentation/output/}"
- mkdir -p "${dst%/*}"
- mv "$src" "$dst"
- rmdir -p --ignore-fail-on-non-empty "${src%/*}"
- done < <(find "$builddir/Documentation/output" -type f -print0)
-
msg2 "Adding symlink..."
mkdir -p "$pkgdir/usr/share/doc"
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"