summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-13 18:45:25 +0300
committerDimitris Kiziridis2020-05-13 18:45:25 +0300
commit2eeeefa3e6a0d4fe4e2d123668b1152bcc922b46 (patch)
treef534b0fdc5c4501cfcaf562c5e690f090abd3f97
parentb44ad9b8498b9824794b7c6ad2c49399c79ae89c (diff)
downloadaur-2eeeefa3e6a0d4fe4e2d123668b1152bcc922b46.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 6 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7e32ee50055..765faa28f3ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = linuxcnc
- pkgdesc = LinuxCNC controls CNC machines. It can drive milling machines, lathes, 3d printers, laser cutters, plasma cutters, robot arms, hexapods, and more (formerly EMC2)
+ pkgdesc = Controls CNC machines. It can drive milling machines, lathes, 3d printers, laser cutters, plasma cutters, robot arms, hexapods, and more (formerly EMC2)
pkgver = 2.7.15
pkgrel = 1
url = http://linuxcnc.org
arch = i686
arch = x86_64
- license = GPL-2.0
+ license = GPL2
makedepends = intltool
depends = bc
depends = bwidget
- depends = tcl
- depends = tk
+ depends = libxaw
depends = python2-imaging
depends = python2-yapps2
depends = tkimg
@@ -18,8 +17,6 @@ pkgbase = linuxcnc
depends = tclx
depends = xorg-server
depends = boost
- depends = boost-libs
- depends = libtirpc
depends = procps-ng
depends = psmisc
source = linuxcnc-2.7.15.tar.gz::https://github.com/LinuxCNC/linuxcnc/archive/v2.7.15.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 66cedbf619d6..29f667b4fbeb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,13 @@
pkgname=linuxcnc
pkgver=2.7.15
pkgrel=1
-pkgdesc="LinuxCNC controls CNC machines. It can drive milling machines, lathes, 3d printers, laser cutters, plasma cutters, robot arms, hexapods, and more (formerly EMC2)"
+pkgdesc="Controls CNC machines. It can drive milling machines, lathes, 3d printers, laser cutters, plasma cutters, robot arms, hexapods, and more (formerly EMC2)"
arch=('i686' 'x86_64')
-license=('GPL-2.0')
+license=('GPL2')
url="http://linuxcnc.org"
depends=('bc'
'bwidget'
- 'tcl'
- 'tk'
+ 'libxaw'
'python2-imaging'
'python2-yapps2'
'tkimg'
@@ -20,8 +19,6 @@ depends=('bc'
'tclx'
'xorg-server'
'boost'
- 'boost-libs'
- 'libtirpc'
'procps-ng'
'psmisc')
makedepends=('intltool')
@@ -58,6 +55,4 @@ package() {
"${pkgdir}/etc/profile.d/${pkgname}.sh"
sed -i "s|${srcdir}||" "${pkgdir}/usr/include/linuxcnc/config.h"
sed -i "s|${srcdir}||" "${pkgdir}/usr/share/linuxcnc/Makefile.modinc"
- install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}"
- ln -s /usr/share/licenses/common/GPL2/license.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
} \ No newline at end of file