summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-10-30 00:07:24 +0100
committerFabioLolix2023-10-30 00:07:24 +0100
commit66777fe3127691f242fe7dffcfc0fd058baf6682 (patch)
treeb4ca9ee0b723304bb8c97e75989c534e677e46e4
parentffb74c0afe6463aa71828b51051ec0271372bef1 (diff)
downloadaur-66777fe3127691f242fe7dffcfc0fd058baf6682.tar.gz
v2.9.1
-rw-r--r--.SRCINFO73
-rw-r--r--PKGBUILD67
-rw-r--r--unredestributable.txt5
3 files changed, 90 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c620aad743dc..b9a7fe4c8edc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,64 @@
pkgbase = linuxcnc
pkgdesc = Controls CNC machines. It can drive milling machines, lathes, 3d printers, laser cutters, plasma cutters, robot arms, hexapods, and more (formerly EMC2)
- pkgver = 2.8.4
+ pkgver = 2.9.1
pkgrel = 1
url = http://linuxcnc.org
- arch = i686
arch = x86_64
license = GPL2
+ license = custom: unredestributable
makedepends = intltool
- depends = bc
- depends = bwidget
- depends = libxaw
- depends = boost-python2
- depends = python2-gobject
- depends = python2-imaging
- depends = python2-yapps2
- depends = tkimg
- depends = python2-gtkglext
- depends = tclx
- depends = xorg-server
- depends = boost
- depends = procps-ng
- depends = psmisc
- conflicts = linuxcnc-git
- conflicts = linuxcnc-bin
- source = linuxcnc-2.8.4.tar.gz::https://github.com/LinuxCNC/linuxcnc/archive/refs/tags/v2.8.4.tar.gz
+ makedepends = boost
+ makedepends = asciidoc
+ makedepends = glu
+ makedepends = procps-ng
+ makedepends = psmisc
+ makedepends = bwidget
+ makedepends = tclx
+ depends = glibc
+ depends = python
+ depends = gtk3
+ depends = libusb
+ depends = libxss
+ depends = python-cairo
+ depends = gobject-introspection-runtime
+ depends = dbus-python
+ depends = python-pillow
+ depends = libxmu
+ depends = python-gobject
+ depends = tk
+ depends = python-matplotlib
+ depends = boost-libs
+ depends = python-numpy
+ depends = gstreamer
+ depends = at-spi2-core
+ depends = libepoxy
+ depends = libtirpc
+ depends = libxft
+ depends = harfbuzz
+ depends = gcc-libs
+ depends = fontconfig
+ depends = gdk-pixbuf2
+ depends = libxext
+ depends = librsvg
+ depends = glib2
+ depends = zlib
+ depends = cairo
+ depends = readline
+ depends = systemd-libs
+ depends = freetype2
+ depends = libx11
+ depends = libxinerama
+ depends = python-configobj
+ depends = libgpiod
+ depends = python-yapps2
+ depends = tcl
+ depends = pango
+ options = !emptydirs
+ source = linuxcnc-2.9.1.tar.gz::https://github.com/LinuxCNC/linuxcnc/archive/refs/tags/v2.9.1.tar.gz
+ source = unredestributable.txt
source = libtirpc.patch
- sha256sums = d2c6950e011e462fdc50cc60d728bf3596d9ff1e0493fe0a174dd8724ab318c3
+ sha256sums = e9cf46c9a29bd1f93628bae5d554dbb19be84a4e0752e205fd259cb0de3453a3
+ sha256sums = 228a035c143ccbdd6056e1189267b034f046742cae034bff821eccc8dbc68ee3
sha256sums = bc95bafd67fad1c1d3722261bc586cdc612ec9e1597fadb95fa825c10550ac2c
pkgname = linuxcnc
diff --git a/PKGBUILD b/PKGBUILD
index 0d994f53cc2b..33b4117cf5f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,26 @@
-# Maintainer: Jason Kercher <jkercher43 a gmail>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Jason Kercher <jkercher43 a gmail>
# Contributor: Peter Ivanov <ivanovp@gmail.com>
# Contributor: Alec Ari <neotheuser@ymail.com>
pkgname=linuxcnc
-pkgver=2.8.4
+pkgver=2.9.1
pkgrel=1
pkgdesc="Controls CNC machines. It can drive milling machines, lathes, 3d printers, laser cutters, plasma cutters, robot arms, hexapods, and more (formerly EMC2)"
-arch=('i686' 'x86_64')
-license=('GPL2')
+arch=(x86_64)
+license=(GPL2 'custom: unredestributable')
url="http://linuxcnc.org"
-depends=('bc'
- 'bwidget'
- 'libxaw'
- 'boost-python2'
- 'python2-gobject'
- 'python2-imaging'
- 'python2-yapps2'
- 'tkimg'
- 'python2-gtkglext'
- 'tclx'
- 'xorg-server'
- 'boost'
- 'procps-ng'
- 'psmisc')
-makedepends=('intltool')
-conflicts=('linuxcnc-git' 'linuxcnc-bin')
-
+depends=(glibc python gtk3 libusb libxss python-cairo gobject-introspection-runtime dbus-python python-pillow libxmu
+ python-gobject tk python-matplotlib boost-libs python-numpy gstreamer at-spi2-core libepoxy libtirpc libxft
+ harfbuzz gcc-libs fontconfig gdk-pixbuf2 libxext librsvg glib2 zlib cairo readline systemd-libs freetype2
+ libx11 libxinerama python-configobj libgpiod python-yapps2 tcl pango)
+makedepends=(intltool boost asciidoc glu procps-ng psmisc bwidget tclx)
+options=(!emptydirs)
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/LinuxCNC/linuxcnc/archive/refs/tags/v${pkgver}.tar.gz"
+ 'unredestributable.txt'
'libtirpc.patch')
-sha256sums=('d2c6950e011e462fdc50cc60d728bf3596d9ff1e0493fe0a174dd8724ab318c3'
+sha256sums=('e9cf46c9a29bd1f93628bae5d554dbb19be84a4e0752e205fd259cb0de3453a3'
+ '228a035c143ccbdd6056e1189267b034f046742cae034bff821eccc8dbc68ee3'
'bc95bafd67fad1c1d3722261bc586cdc612ec9e1597fadb95fa825c10550ac2c')
prepare() {
@@ -37,15 +29,20 @@ prepare() {
find . -iname fixpaths.py -o -iname checkglade -o \
-iname update_ini | xargs perl -p -i -e "s/python/python2/"
patch -Np2 -i $srcdir/libtirpc.patch
+
./autogen.sh
- ./configure --with-realtime=uspace \
- --without-libmodbus --prefix=/usr \
- --with-python=/usr/bin/python2.7 \
- --enable-non-distributable=yes
+
+ ./configure \
+ --prefix=/usr \
+ --enable-non-distributable=yes \
+ --with-realtime=uspace \
+ --without-libmodbus \
+ --disable-gtk2
+
# Linking time errors fix
- sed -i "163s|FileName|FileNameArr|" hal/classicladder/files_project.c
- sed -i "174s|FileName|FileNameArr|g" hal/classicladder/files_project.c
- sed -i "175s|FileName|FileNameArr|" hal/classicladder/files_project.c
+ #sed -i "163s|FileName|FileNameArr|" hal/classicladder/files_project.c
+ #sed -i "174s|FileName|FileNameArr|g" hal/classicladder/files_project.c
+ #sed -i "175s|FileName|FileNameArr|" hal/classicladder/files_project.c
}
build () {
@@ -55,13 +52,13 @@ build () {
package() {
cd "${srcdir}/${pkgname}-${pkgver}/src"
- DESTDIR=${pkgdir} make install
+ DESTDIR=${pkgdir} make install
cp -PR "${srcdir}/${pkgname}-${pkgver}/share/applications" $pkgdir/usr/share
mkdir -p "${pkgdir}/etc/xdg"
cp -PR "${srcdir}/${pkgname}-${pkgver}/share/menus" "${pkgdir}/etc/xdg/"
- install -Dm755 "${srcdir}/${pkgname}-${pkgver}/src/${pkgname}.sh" \
- "${pkgdir}/etc/profile.d/${pkgname}.sh"
- sed -i "s|${srcdir}||" "${pkgdir}/usr/include/linuxcnc/config.h"
- sed -i "s|${srcdir}||" "${pkgdir}/usr/share/linuxcnc/Makefile.modinc"
- install -Dm 644 "${srcdir}/${pkgname}-${pkgver}/src/linuxcnc.sh" -t "${pkgdir}/etc/profile.d/"
+ install -Dm755 "${srcdir}/${pkgname}-${pkgver}/src/${pkgname}.sh" "${pkgdir}/etc/profile.d/${pkgname}.sh"
+ #sed -i "s|${srcdir}||" "${pkgdir}/usr/include/linuxcnc/config.h"
+ #sed -i "s|${srcdir}||" "${pkgdir}/usr/share/linuxcnc/Makefile.modinc"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/src/linuxcnc.sh" -t "${pkgdir}/etc/profile.d/"
+ install -D -t "${pkgdir}/usr/share/licenses/${pkgname}" "${srcdir}/unredestributable.txt"
}
diff --git a/unredestributable.txt b/unredestributable.txt
new file mode 100644
index 000000000000..a2c93f161857
--- /dev/null
+++ b/unredestributable.txt
@@ -0,0 +1,5 @@
+checking whether readline license is compatible with GPL-2... no
+configure: WARNING: The LinuxCNC binary you are building may not be
+distributable due to a license incompatibility with LinuxCNC (some portions
+GPL-2 only) and Readline version 6 and greater (GPL-3 or later).
+configure: WARNING: User requested to enable non-distributable builds. Continuing.