summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-11-15 17:51:19 +0000
committerGonçalo Camelo Neves Pereira2018-11-15 17:51:19 +0000
commitff19f25303ca1802c4738e4bc5c62da7c78aaa90 (patch)
tree0cd578b348f826cb777a3408381d13acc7e64d37
parentafee30233d8e18b18995426d2574da9f3c8ab9d8 (diff)
downloadaur-ff19f25303ca1802c4738e4bc5c62da7c78aaa90.tar.gz
Fix Dependencies and cleaned PKGBUILD
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD25
-rw-r--r--boost.patch11
-rw-r--r--image-to-gcode.patch11
-rwxr-xr-xpre-commit5
5 files changed, 8 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e15b0c332e54..4dfa07245e4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = linuxcnc-sim
pkgdesc = It can interpret G-code and simulate a CNC machine (formerly EMC2).
pkgver = 2.7.14
- pkgrel = 1
+ pkgrel = 2
url = http://linuxcnc.org/
install = linuxcnc-sim.install
arch = i686
arch = x86_64
license = GPL2
makedepends = git
+ makedepends = intltool
depends = bc
depends = bwidget
depends = tcl
@@ -20,14 +21,12 @@ pkgbase = linuxcnc-sim
depends = boost
depends = boost-libs
depends = libtirpc
+ depends = procps-ng
+ depends = psmisc
source = linuxcnc::git://github.com/LinuxCNC/linuxcnc.git#tag=v2.7.14
- source = boost.patch
- source = image-to-gcode.patch
source = linuxcnc-sim.sh
source = libtirpc.patch
md5sums = SKIP
- md5sums = ba6948dc5dc155849f55039e454cdbd6
- md5sums = c31d34a7ba567bd664f362a52f8bb03b
md5sums = 3fb3f231cfefdfe1fa4d600ecbf4a3cb
md5sums = 42770a1aa791172358700e4d5af335ed
diff --git a/PKGBUILD b/PKGBUILD
index 58d26580a440..574a1c628470 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,20 @@
pkgname=linuxcnc-sim
pkgver=2.7.14
-pkgrel=1
+pkgrel=2
pkgdesc="It can interpret G-code and simulate a CNC machine (formerly EMC2)."
arch=('i686' 'x86_64')
license=('GPL2')
url="http://linuxcnc.org/"
-depends=('bc' 'bwidget' 'tcl' 'tk' 'xorg-server' 'python2-imaging' 'tkimg' 'python2-gtkglext' 'tclx' 'boost' 'boost-libs' 'libtirpc')
+depends=('bc' 'bwidget' 'tcl' 'tk' 'xorg-server' 'python2-imaging' 'tkimg' 'python2-gtkglext' 'tclx' 'boost' 'boost-libs' 'libtirpc' 'procps-ng' 'psmisc')
install=$pkgname.install
_gitname='linuxcnc'
-source=($_gitname::"git://github.com/LinuxCNC/linuxcnc.git#tag=v$pkgver" 'boost.patch' 'image-to-gcode.patch' 'linuxcnc-sim.sh' 'libtirpc.patch')
+source=($_gitname::"git://github.com/LinuxCNC/linuxcnc.git#tag=v$pkgver" 'linuxcnc-sim.sh' 'libtirpc.patch')
#source=($_gitname::'git://git.linuxcnc.org/git/linuxcnc.git#tag=739df958aca9d246daad36f439c82bfbeac681b9' 'boost.patch')
md5sums=('SKIP'
- 'ba6948dc5dc155849f55039e454cdbd6'
- 'c31d34a7ba567bd664f362a52f8bb03b'
'3fb3f231cfefdfe1fa4d600ecbf4a3cb'
'42770a1aa791172358700e4d5af335ed')
-makedepends=('git')
+makedepends=('git' 'intltool')
PKGEXT='.pkg.tar'
#pkgver() {
@@ -29,24 +27,9 @@ PKGEXT='.pkg.tar'
build () {
find . -iname fixpaths.py -o -iname checkglade -o -iname update_ini|xargs perl -p -i -e "s/python/python2/"
cd $srcdir/$_gitname/src
-# patch -p0 <../../image-to-gcode.patch
-# patch -p1 <../../boost.patch
-# #This Makefile line fixes a seg fault due to changed CFLAGS
-# cp -PR $srcdir/Makefile $srcdir/$pkgname-$pkgver/src/Makefile
-# #This fixes build for updated Python libraries
-# cp -PR $srcdir/Submakefile $srcdir/$pkgname-$pkgver/src/hal/drivers/Submakefile
-# #Another Python fix
-# cd $srcdir/$pkgname-$pkgver
-# patch -Np1 < $srcdir/jepler-modsilent.patch
patch -Np2 -i $srcdir/libtirpc.patch
-# cd $srcdir/$pkgname-$pkgver/src
-# CFLAGS+=" -I/usr/include/tirpc/"
- CXXFLAGS+=" -I/usr/include/tirpc/"
- CPPFLAGS+=" -I/usr/include/tirpc/"
- INCLUDE+=" -I/usr/include/tirpc/"
- LDFLAGS+=" -ltirpc"
./autogen.sh
./configure --with-realtime=uspace --without-libmodbus --prefix=/usr --with-python=/usr/bin/python2.7 --enable-non-distributable=yes
make
diff --git a/boost.patch b/boost.patch
deleted file mode 100644
index e7d1b2aceb99..000000000000
--- a/boost.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./emc/rs274ngc/rs274ngc_pre.cc 2014-10-22 06:40:15.674483981 +0200
-+++ ./emc/rs274ngc/rs274ngc_pre.cc 2014-10-22 06:40:30.550990352 +0200
-@@ -129,7 +129,7 @@
- // since interp.init() may be called repeatedly this would create a new
- // wrapper instance on every init(), abandoning the old one and all user attributes
- // tacked onto it, so make sure this is done exactly once
-- _setup.pythis = boost::python::object(boost::cref(this));
-+ _setup.pythis = boost::python::object(boost::cref(*this));
-
- // alias to 'interpreter.this' for the sake of ';py, .... ' comments
- // besides 'this', eventually use proper instance names to handle
diff --git a/image-to-gcode.patch b/image-to-gcode.patch
deleted file mode 100644
index 95f4607328d0..000000000000
--- a/image-to-gcode.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- image-to-gcode 2016-04-23 08:02:14.000000000 +0200
-+++ emc/usr_intf/axis/scripts/image-to-gcode.py 2016-04-23 08:00:16.004178946 +0200
-@@ -23,7 +23,7 @@
- import gettext;
- gettext.install("linuxcnc", localedir=os.path.join(BASE, "share", "locale"), unicode=True)
-
--import Image
-+from PIL import Image
-
- try:
- import numpy.numarray as numarray
diff --git a/pre-commit b/pre-commit
deleted file mode 100755
index 3c02b611e1ef..000000000000
--- a/pre-commit
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/bash
-
-mksrcinfo
-git add -f .SRCINFO
-exit 0