summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Lau2018-03-28 16:56:03 +0200
committerSebastian Lau2018-03-28 16:56:03 +0200
commitb8a59681ec49f7282da257b0f79782814ede7973 (patch)
tree8f311c719e93dcbf8164f1f19b1fb56927ff57ab
downloadaur-b8a59681ec49f7282da257b0f79782814ede7973.tar.gz
ADD v20180317
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f11c7b120cbc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = linuxdeployqt
+ pkgdesc = Makes Linux applications self-contained by copying in the libraries and plugins that the application uses
+ pkgver = 20180317
+ pkgrel = 1
+ url = https://github.com/probonopd/linuxdeployqt
+ arch = x86_64
+ license = GPL3
+ license = LGPL3
+ makedepends = git
+ makedepends = cmake
+ depends = qt5-base
+ depends = patchelf
+ provides = linuxdeployqt
+ source = git+https://github.com/probonopd/linuxdeployqt.git#commit=8b484dabec41c40b6553e965c1928d5c94f961e6
+ md5sums = SKIP
+
+pkgname = linuxdeployqt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29ec40dc5a64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Sebastian Lau <lauseb644@gmail.com>
+
+pkgname="linuxdeployqt"
+pkgver=20180317
+pkgrel=1
+pkgdesc="Makes Linux applications self-contained by copying in the libraries and plugins that the application uses"
+arch=('x86_64')
+url="https://github.com/probonopd/linuxdeployqt"
+license=('GPL3' 'LGPL3')
+depends=('qt5-base' 'patchelf')
+makedepends=('git' 'cmake')
+provides=('linuxdeployqt')
+_commit="8b484dabec41c40b6553e965c1928d5c94f961e6"
+source=("git+https://github.com/probonopd/linuxdeployqt.git#commit=${_commit}")
+md5sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}"
+ [[ -e build ]] && rm -r build
+ mkdir build
+}
+
+build() {
+ cd "${srcdir}/build"
+ cmake ../${pkgname}
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+
+ install -d "${pkgdir}/usr/bin"
+ install "tools/linuxdeployqt/linuxdeployqt" "${pkgdir}/usr/bin/linuxdeployqt"
+}
+
+# vim:set ts=2 sw=2 et: