summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirikaze Chiyuki2024-04-13 21:28:48 +0800
committerKirikaze Chiyuki2024-04-13 21:28:48 +0800
commit9b4d89569bff09c4f74bb8d43cd77ed1e306bcd3 (patch)
tree955f67998dc17b646173a9e72ac3cac3480576fb
parent75d01f8b4446269708922c808453b435943b21c1 (diff)
downloadaur-9b4d89569bff09c4f74bb8d43cd77ed1e306bcd3.tar.gz
[fix] Wayland 下鼠标指针不正确问题
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xstart.sh1
-rwxr-xr-xxdg-open.sh4
4 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbdb0e8c1c28..ad68a6d6f1d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linuxqq-nt-bwrap
pkgdesc = New Linux QQ based on Electron, with bubblewrap sandbox and some tweaks
pkgver = 3.2.7_240412
- pkgrel = 1
+ pkgrel = 2
url = https://im.qq.com/linuxqq/index.shtml
install = linuxqq-nt-bwrap.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 43098a4fb53f..77257b7d54c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _base_pkgver=3.2.7_240412
_update_pkgver=${_base_pkgver}
pkgname=linuxqq-nt-bwrap
pkgver="${_update_pkgver//-/_}"
-pkgrel=1
+pkgrel=2
pkgdesc="New Linux QQ based on Electron, with bubblewrap sandbox and some tweaks"
arch=('x86_64' 'aarch64' 'loong64')
url='https://im.qq.com/linuxqq/index.shtml'
diff --git a/start.sh b/start.sh
index 7aed024dce5f..eb7d4d9e23a6 100755
--- a/start.sh
+++ b/start.sh
@@ -120,6 +120,7 @@ bwrap --new-session --cap-drop ALL --unshare-user-try --unshare-pid --unshare-cg
--ro-bind-try "${HOME}/.icons" "${HOME}/.icons" \
--ro-bind-try "${HOME}/.local/share/.icons" "${HOME}/.local/share/.icons" \
--ro-bind-try "${XDG_CONFIG_HOME}/gtk-3.0" "${XDG_CONFIG_HOME}/gtk-3.0" \
+ --ro-bind-try "${XDG_CONFIG_HOME}/dconf" "${XDG_CONFIG_HOME}/dconf" \
--ro-bind /etc/nsswitch.conf /etc/nsswitch.conf \
--ro-bind /run/systemd/userdb/ /run/systemd/userdb/ \
--setenv IBUS_USE_PORTAL 1 \
diff --git a/xdg-open.sh b/xdg-open.sh
index cfdc9c1da0a8..e3c10870a031 100755
--- a/xdg-open.sh
+++ b/xdg-open.sh
@@ -5,6 +5,10 @@ URI_TO_OPEN="$1"
# 一个是为了打开链接,一个是为了使用本地图片查看器打开本地图片
# 请不要因为你认为依赖重复就把软件包标记为过期
+# 2024.04.13 Update: 现在 flatpak-xdg-open 可以打开链接了
+# 但是反应极其迟缓,点击链接之后需要等待大概半分钟才能打开
+# 因此,snapd-xdg-open 依赖仍然保留
+
if ! [ "${URI_TO_OPEN:0:8}" == "jsbridge" ]; then
if [ "${URI_TO_OPEN:0:4}" == "http" ]; then
/snapd-xdg-open "$URI_TO_OPEN"