summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-13 11:20:34 -0600
committerBrian Bidulock2015-07-13 11:20:34 -0600
commita8743acfcd88a49b6de37e38b57c57e06af65418 (patch)
treeec26f9dab0d11a95fe6c5e56fbab4fa6ca11553c
downloadaur-a8743acfcd88a49b6de37e38b57c57e06af65418.tar.gz
initial version
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD40
-rw-r--r--linuxstopmotion.install9
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7cb4bbf3dc9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = linuxstopmotion-git
+ pkgdesc = software for capturing and creating stop-motion animations - development version
+ pkgver = 0.8.1beta3.r0.gf34923c
+ pkgrel = 1
+ epoch = 1
+ url = http://www.linuxstopmotion.org
+ install = linuxstopmotion.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = libtar
+ depends = qt4
+ depends = sdl_image
+ depends = libvorbis
+ depends = libxml2
+ conflicts = stopmotion
+ source = linuxstopmotion::git+http://git.code.sf.net/p/linuxstopmotion/code#branch=ioctl-autodetect
+ md5sums = SKIP
+
+pkgname = linuxstopmotion-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1283b4a49c77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Mark Coolen <mark dot coolen at gmail dot com>
+pkgname=linuxstopmotion-git
+_realname=linuxstopmotion
+pkgver=0.8.1beta3.r0.gf34923c
+pkgrel=1
+epoch=1
+pkgdesc="software for capturing and creating stop-motion animations - development version"
+arch=('i686' 'x86_64')
+url="http://www.linuxstopmotion.org"
+license=('GPL2')
+depends=('qt4' 'sdl_image' 'libvorbis' 'libxml2')
+makedepends=('git' 'libtar')
+install=$_realname.install
+conflicts=('stopmotion')
+source=("$_realname::git+http://git.code.sf.net/p/$_realname/code#branch=ioctl-autodetect")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_realname"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_realname"
+ lrelease-qt4 stopmotion.pro
+ qmake-qt4 PREFIX=/usr stopmotion.pro
+ sed -i '/^LIBS/s|$| -lX11|' Makefile
+ make
+}
+
+package() {
+ cd "$srcdir/$_realname"
+ sed -e 's/install_desktop install_dummy/install_desktop/' -i Makefile.Release
+ make INSTALL_ROOT="$pkgdir" install
+ install -D -m644 stopmotion.desktop "$pkgdir"/usr/share/applications/stopmotion.desktop
+ install -D -m644 graphics/stopmotion.png "$pkgdir"/usr/share/pixmaps/stopmotion.png
+ install -D -m644 stopmotion.mime "$pkgdir"/usr/share/mime-info/stopmotion.mime
+ install -D -m644 stopmotion.1 "$pkgdir"/usr/share/man/man1/stopmotion.1
+ gzip "$pkgdir"/usr/share/man/man1/stopmotion.1
+}
diff --git a/linuxstopmotion.install b/linuxstopmotion.install
new file mode 100644
index 000000000000..1206f9708734
--- /dev/null
+++ b/linuxstopmotion.install
@@ -0,0 +1,9 @@
+post_install() {
+ xdg-mime install --novendor /usr/share/mime-info/stopmotion.mime
+ update-desktop-database -q
+}
+
+pre_remove() {
+ xdg-mime uninstall /usr/share/mime-info/stopmotion.mime
+ update-desktop-database -q
+} \ No newline at end of file