summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-06 21:58:08 +0100
committerBartłomiej Piotrowski2018-01-06 21:58:08 +0100
commita905faffd77533acfd44e5939d3340319eb3c2a2 (patch)
treef4e92fdeb15ce971044ef63f7fac8784fb78064f
downloadaur-a905faffd77533acfd44e5939d3340319eb3c2a2.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD40
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2690db3bae2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = linuxtv-dvb-apps
+ pkgdesc = Linux DVB API applications and utilities
+ pkgver = 1504
+ pkgrel = 1
+ url = http://www.linuxtv.org/
+ arch = x86_64
+ license = GPL
+ makedepends = mercurial
+ depends = glibc
+ source = hg+http://linuxtv.org/hg/dvb-apps/#revision=d40083fff895
+ sha256sums = SKIP
+
+pkgname = linuxtv-dvb-apps
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be48a79069aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Jonathan Conder <jonno.conder@gmail.com>
+# Contributor: Jaroslaw Swierczynski <swiergot@aur.archlinux.org>
+# Contributor: Camille Moncelier <pix@devlife.org>
+
+pkgname=linuxtv-dvb-apps
+pkgver=1504
+pkgrel=1
+_hgrev=d40083fff895
+pkgdesc='Linux DVB API applications and utilities'
+arch=('x86_64')
+url='http://www.linuxtv.org/'
+license=('GPL')
+depends=('glibc')
+makedepends=('mercurial')
+source=("hg+http://linuxtv.org/hg/dvb-apps/#revision=$_hgrev")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "dvb-apps"
+ echo $(hg identify -n)
+}
+
+prepare() {
+ cd "dvb-apps"
+ # Fix build
+ sed -i '/$(sharedir)\/dvb\//d' util/scan/Makefile
+}
+
+build() {
+ cd "dvb-apps"
+ make
+}
+
+package() {
+ cd "dvb-apps"
+ make DESTDIR="$pkgdir" install
+ # Remove conflict with xbase (FS#37862)
+ mv "$pkgdir"/usr/bin/{zap,dvbzap}
+}