summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Dimitrijevic2024-04-02 10:59:30 +0200
committerStefan Dimitrijevic2024-04-02 10:59:30 +0200
commit47ecda00cbcd5c0e09451e05df61630d2bc6a337 (patch)
treee2a9a104e0c32ded0a40eeb78f8f1a3e3da050ea
downloadaur-47ecda00cbcd5c0e09451e05df61630d2bc6a337.tar.gz
initial aur release
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD55
-rw-r--r--linvam.install14
3 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b544c9bb7094
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = linvam
+ pkgdesc = Linux voice activated macros
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/stele95/LinVAM
+ install = linvam.install
+ arch = x86_64
+ license = GPL3
+ makedepends = python
+ makedepends = nuitka
+ makedepends = git
+ makedepends = bash
+ depends = python
+ depends = python-pyqt6
+ depends = python-srt
+ depends = python-requests
+ depends = python-tqdm
+ depends = python-sounddevice
+ depends = python-vosk
+ depends = ffmpeg
+ depends = ydotool
+ depends = bash
+ provides = linvam
+ provides = linvamrun
+ conflicts = linvam
+ conflicts = linvamrun
+ options = debug
+ source = https://github.com/stele95/LinVAM/archive/refs/tags/v0.5.0.tar.gz
+ sha256sums = SKIP
+
+pkgname = linvam
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32e2aab5068a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Stefan Dimitrijevic <stefanstele95@hotmail.com>
+
+pkgname='linvam'
+pkgver=0.5.0
+pkgrel=1
+pkgdesc='Linux voice activated macros'
+arch=('x86_64')
+url='https://github.com/stele95/LinVAM'
+arch=('x86_64')
+license=('GPL3')
+makedepends=(
+ 'python'
+ 'nuitka'
+ 'git'
+ 'bash'
+)
+depends=(
+ 'python'
+ 'python-pyqt6'
+ 'python-srt'
+ 'python-requests'
+ 'python-tqdm'
+ 'python-sounddevice'
+ 'python-vosk'
+ 'ffmpeg'
+ 'ydotool'
+ 'bash'
+)
+provides=(
+ 'linvam'
+ 'linvamrun'
+)
+conflicts=(
+ 'linvam'
+ 'linvamrun'
+)
+source=("$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('SKIP')
+options=('debug')
+install=linvam.install
+
+build() {
+ current_CFLAGS=$CFLAGS
+ export CFLAGS=''
+ cd "LinVAM-$pkgver"/scripts
+ sh ./build.sh
+ export CFLAGS=$current_CFLAGS
+}
+
+package() {
+ install "LinVAM-$pkgver"/src/LinVAM.desktop -Dm644 "$pkgdir/usr/share/applications/LinVAM.desktop"
+ install "LinVAM-$pkgver"/scripts/linvam -Dm755 "$pkgdir/usr/bin/linvam"
+ install "LinVAM-$pkgver"/scripts/linvamrun -Dm755 "$pkgdir/usr/bin/linvamrun"
+ install "LinVAM-$pkgver"/LICENSE.txt -Dm644 "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}
diff --git a/linvam.install b/linvam.install
new file mode 100644
index 000000000000..4441bf986c36
--- /dev/null
+++ b/linvam.install
@@ -0,0 +1,14 @@
+post_install() {
+ echo '#######################################################################################'
+ echo '#######################################################################################'
+ echo '#### ####'
+ echo '#### Make sure your user is in the `input` group by running the following command: ####'
+ echo '#### sudo usermod -aG input $USER ####'
+ echo '#### ####'
+ echo '#######################################################################################'
+ echo '#######################################################################################'
+}
+
+post_upgrade() {
+ post_install
+}