summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSangeppato2019-02-01 16:49:24 +0100
committerSangeppato2019-02-01 16:49:24 +0100
commitb05b352322303e4cd43bcee5fd9f4de71876b481 (patch)
tree8c7180260448a8d7cdabf78c6e65db3a147fca0b
downloadaur-b05b352322303e4cd43bcee5fd9f4de71876b481.tar.gz
First commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ceffdbbaaa1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = linvst-stable
+ pkgdesc = Bridge that allows Windows vst's to be used as Linux vst's in Linux vst capable DAW's
+ pkgver = 2.4
+ pkgrel = 1
+ url = https://github.com/osxmidi/LinVst
+ arch = x86_64
+ license = GPL
+ makedepends = gtk3
+ depends = wine
+ provides = linvst
+ conflicts = linvst
+ conflicts = linvst-git
+ conflicts = linvst-bin
+ source = https://github.com/osxmidi/LinVst/archive/2.4.tar.gz
+ sha256sums = 8d569804b5d0bbc305283d1f2d8ff7c04f9150bd7208a6d86feabbd17bdd34d7
+
+pkgname = linvst-stable
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42f11f7cfb6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+pkgname=linvst-stable
+pkgver=2.4
+pkgrel=1
+
+_pkgname=LinVst
+
+provides=('linvst')
+conflicts=('linvst' 'linvst-git' 'linvst-bin')
+
+pkgdesc="Bridge that allows Windows vst's to be used as Linux vst's in Linux vst capable DAW's"
+url="https://github.com/osxmidi/LinVst"
+arch=('x86_64')
+license=('GPL')
+
+depends=('wine')
+makedepends=('gtk3')
+
+source=("https://github.com/osxmidi/${_pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('8d569804b5d0bbc305283d1f2d8ff7c04f9150bd7208a6d86feabbd17bdd34d7')
+
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make -f Makefile-embed-6432 DESTDIR="${pkgdir}" all
+ cd "convert"
+ sh makegtk3
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make -f Makefile-embed-6432 DESTDIR="${pkgdir}" VST_DIR="${pkgdir}/usr/share/${_pkgname}" install
+ install -m 755 "convert/linvstconvert" "${pkgdir}/usr/bin/"
+}