summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoruser.name2020-03-07 17:45:19 -0500
committeruser.name2020-03-07 17:45:19 -0500
commit34e3d8e4a326d8c6fee7b9969fd159b5b1c53ccc (patch)
tree4cb8ef8401d19333487565dedf841a6432aebbc6
parent9c9dc10ca71e6823956667622258b5e2da19c27d (diff)
downloadaur-linvst2.tar.gz
small source fix
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 266287a7fc40..04a11d2126fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = linvst2
pkgdesc = enables Windows vst's to be used as Linux vst's in Linux vst capable DAW's
pkgver = 2.8
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/osxmidi/LinVst
arch = x86_64
+ makedepends = git
depends = wine
depends = python>=3.8
conflicts = linvst
conflicts = linvst-stable
- source = linvst2::git+https://github.com/osxmidi/LinVst.git#tag=2.8
+ source = https://github.com/osxmidi/LinVst/archive/2.8.zip
source = git+https://github.com/usrmusicman/ArchStudioUtils.git
- sha256sums = SKIP
+ sha256sums = c955a6fce5e4d8a6014dd2e7daed8ddca1f57ca9e394caf69f93c4f55b892a48
sha256sums = SKIP
pkgname = linvst2
diff --git a/PKGBUILD b/PKGBUILD
index 8238b5d321ba..810f125a333d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,25 @@
pkgname=linvst2
pkgver=2.8
-pkgrel=4
+pkgrel=5
pkgdesc="enables Windows vst's to be used as Linux vst's in Linux vst capable DAW's"
arch=('x86_64')
url="https://github.com/osxmidi/LinVst"
depends=('wine' 'python>=3.8')
+makedepends=('git')
conflicts=('linvst' 'linvst-stable')
-source=("$pkgname::git+https://github.com/osxmidi/LinVst.git#tag=$pkgver"
+source=("https://github.com/osxmidi/LinVst/archive/${pkgver}.zip"
"git+https://github.com/usrmusicman/ArchStudioUtils.git")
-sha256sums=('SKIP'
+sha256sums=('c955a6fce5e4d8a6014dd2e7daed8ddca1f57ca9e394caf69f93c4f55b892a48'
'SKIP')
build() {
- cd $srcdir/$pkgname
+ cd $srcdir/LinVst-${pkgver}
make -f Makefile-embed-6432 DESTDIR="${pkgdir}" all
}
package() {
- cd $srcdir/$pkgname
+ cd $srcdir/LinVst-${pkgver}
make -f Makefile-embed-6432 DESTDIR="${pkgdir}" VST_DIR="${pkgdir}/usr/bin" install
install -Dm755 $srcdir/ArchStudioUtils/w2lvst2 $pkgdir/usr/bin/w2lvst2
}