summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorusrmusicman2019-10-22 21:48:50 -0400
committerusrmusicman2019-10-22 21:48:50 -0400
commit4a9e9d25aee10179e68e9a582fdfd1b37449f101 (patch)
tree714e6a8a1fc834312c9fbb38d72f1ca8f2342835
parente21f9148dd8400a10968ae5a61298a14097a99c8 (diff)
downloadaur-4a9e9d25aee10179e68e9a582fdfd1b37449f101.tar.gz
Update linvst2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--w2lvst229
3 files changed, 9 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f20e96f2391..49dadf1fc900 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linvst2
pkgdesc = enables Windows vst's to be used as Linux vst's in Linux vst capable DAW's
- pkgver = 2.7.0
- pkgrel = 3
+ pkgver = 2.7.2
+ pkgrel = 1
url = https://github.com/osxmidi/LinVst
arch = x86_64
depends = wine
@@ -10,8 +10,8 @@ pkgbase = linvst2
conflicts = linvst-stable
replaces = linvst
replaces = linvst-stable
- source = https://github.com/osxmidi/LinVst/releases/download/2.7/LinVst-64bit-32bit_2.7.0.deb
- source = w2lvst2
+ source = https://github.com/osxmidi/LinVst/releases/download/2.7/LinVst-64bit-32bit_2.7.2.deb
+ source = https://github.com/usrmusicman/ArchStudioUtils/archive/2.4.zip
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 43b5bf2eeeaa..d38c2bd78e3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
pkgname=linvst2
-pkgver=2.7.0
-pkgrel=3
+pkgver=2.7.2
+pkgver_w2lvst2=2.4
+pkgrel=1
pkgdesc="enables Windows vst's to be used as Linux vst's in Linux vst capable DAW's"
arch=('x86_64')
url="https://github.com/osxmidi/LinVst"
@@ -8,7 +9,7 @@ depends=('wine' 'python>=3.7')
conflicts=('linvst' 'linvst-stable')
replaces=('linvst' 'linvst-stable')
source=("https://github.com/osxmidi/LinVst/releases/download/2.7/LinVst-64bit-32bit_${pkgver}.deb"
- "w2lvst2")
+ "https://github.com/usrmusicman/ArchStudioUtils/archive/${pkgver_w2lvst2}.zip")
sha256sums=('SKIP'
'SKIP')
@@ -25,5 +26,5 @@ package() {
cp -r $srcdir/usr $pkgdir/usr
## Install CLI Linker Program (Python3)
- install -Dm755 w2lvst2 $pkgdir/usr/bin/w2lvst2
+ install -Dm755 $srcdir/ArchStudioUtils-$pkgver/w2lvst2 $pkgdir/usr/bin/w2lvst2
}
diff --git a/w2lvst2 b/w2lvst2
deleted file mode 100644
index cfdba1aa5d7e..000000000000
--- a/w2lvst2
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/usr/bin/python3
-
-# Maintainer: Alexander Mcmillan <linuxguy93@gmail.com>
-
-# Imported Modules
-import os # native OS support
-import shutil # high-level file operations support
-import glob # support globbing *
-import sys # import sytem functions
-
-# Golbal Variables
-linvstfileso="/usr/share/LinVst/64bit-32bit/linvst.so" # the linvst.so bridge file for the linvst bridge
-homedir=os.path.expanduser("~") # expand the current users home directory /home/<user>
-vstdir=(homedir + "/" + ".vst" + "/" + "windows-bridged" + "/") # DAW scanned VST directory
-currentdir=os.getcwd() + "/" # get the current work directory
-
-# Executable Code
-print ("\033[1;38m" + "Start LinVst Bridge Creation" + "\033[0m") # print start message
-os.makedirs(vstdir, exist_ok=True) # create a /home/<user>/<vstdir> directory
-for i in glob.glob("*.dll"): # check for all files with a .dll extension
- vstname, extdll=os.path.splitext(i) # split the filename from its extension, store each value in a seperate variable
- extso=(".so") # the destination exstension .so for Linux DAW compatibility
- shutil.copy2(linvstfileso, vstname + extso) # copy the linvst.so bridge file to match the vstname .dll file. example: plugin.dll, plugin.so
- print("\033[1;33m" + vstname + ": " + "\033[1;36m" + "Link Generated..." + "\033[0m") # print the .so link to be generated
- if os.path.islink(vstdir + vstname + extso): # Check if link exists
- os.remove(vstdir + vstname + extso) # remove old link for vst bridge
- os.symlink(currentdir + vstname + extso, vstdir + vstname + extso) # generate link for vst bridge
- else:
- os.symlink(currentdir + vstname + extso, vstdir + vstname + extso) # generate link for vst bridge