summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorusrmusicman2020-01-11 22:32:16 -0500
committerusrmusicman2020-01-11 22:32:16 -0500
commit6b261dd2b56858e513f1328f34dc20d4a7f88f03 (patch)
tree8a2d829bd0749094a1514b8aa18a315ec8487805
parent347994c9d645c55084cb43f6e421d58eb711f00b (diff)
downloadaur-6b261dd2b56858e513f1328f34dc20d4a7f88f03.tar.gz
Update PKGBUILD to build from source instead of binaries
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 881cfe3b9794..b54d6fd1dda0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,7 @@ pkgbase = linvst2
conflicts = linvst-stable
replaces = linvst
replaces = linvst-stable
- source = https://github.com/osxmidi/LinVst/releases/download/2.8/LinVst-2.8-Debian-Stretch.zip
+ source = linvst2::git+https://github.com/osxmidi/LinVst.git#tag=2.8
source = git+https://github.com/usrmusicman/ArchStudioUtils.git
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 55ef1067cac2..3b4a35cc9b3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,18 +9,18 @@ url="https://github.com/osxmidi/LinVst"
depends=('wine' 'python>=3.8')
conflicts=('linvst' 'linvst-stable')
replaces=('linvst' 'linvst-stable')
-source=("https://github.com/osxmidi/LinVst/releases/download/2.8/LinVst-${pkgver}-Debian-Stretch.zip"
+source=("$pkgname::git+https://github.com/osxmidi/LinVst.git#tag=$pkgver"
"git+https://github.com/usrmusicman/ArchStudioUtils.git")
sha256sums=('SKIP'
'SKIP')
+build() {
+ cd $srcdir/$pkgname
+ make -f Makefile-embed-6432 DESTDIR="${pkgdir}" all
+}
+
package() {
- cd "${srcdir}/LinVst-${pkgver}-Debian-Stretch/embedded/"
- for file in *.so; do
- install -Dm755 $file $pkgdir/usr/bin/$file
- done
- for file in *.exe; do
- install -Dm755 $file $pkgdir/usr/bin/$file
- done
+ cd $srcdir/$pkgname
+ make -f Makefile-embed-6432 DESTDIR="${pkgdir}" VST_DIR="${pkgdir}/usr/bin" install
install -Dm755 $srcdir/ArchStudioUtils/w2lvst2 $pkgdir/usr/bin/w2lvst2
}