summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorusrmusicman2020-01-11 23:34:04 -0500
committerusrmusicman2020-01-11 23:34:04 -0500
commit506d8752332b896f46d6b57922143ce4acd05dd8 (patch)
tree0c106fe375772c302ccdff0be105b0f22b19440a
downloadaur-506d8752332b896f46d6b57922143ce4acd05dd8.tar.gz
add Linvst-X Single wineserver variant
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66297eab95d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = linvst2x
+ pkgdesc = enables Windows vst's to be used as Linux vst's in Linux vst capable DAW's (single wineserver instance variant)
+ pkgver = 2.7
+ pkgrel = 1
+ url = https://github.com/osxmidi/LinVst
+ arch = x86_64
+ depends = wine
+ depends = python>=3.8
+ conflicts = linvst
+ conflicts = linvst-stable
+ conflicts = linvst2
+ source = linvst2x::git+https://github.com/osxmidi/LinVst-X.git#tag=2.7
+ source = git+https://github.com/usrmusicman/ArchStudioUtils.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = linvst2x
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e8912957e9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer Alex Mcmillan <linuxguy93@gmail.com>
+
+pkgname=linvst2x
+pkgver=2.7
+pkgrel=1
+pkgdesc="enables Windows vst's to be used as Linux vst's in Linux vst capable DAW's (single wineserver instance variant)"
+arch=('x86_64')
+url="https://github.com/osxmidi/LinVst"
+depends=('wine' 'python>=3.8')
+conflicts=('linvst' 'linvst-stable' 'linvst2')
+source=("$pkgname::git+https://github.com/osxmidi/LinVst-X.git#tag=$pkgver"
+ "git+https://github.com/usrmusicman/ArchStudioUtils.git")
+sha256sums=('SKIP'
+ 'SKIP')
+
+build() {
+ cd $srcdir/$pkgname
+ make DESTDIR="${pkgdir}" all
+}
+
+package() {
+ cd $srcdir/$pkgname
+ make DESTDIR="${pkgdir}" VST_DIR="${pkgdir}/usr/bin" install
+ install -Dm755 $srcdir/ArchStudioUtils/w2lvst2_X $pkgdir/usr/bin/w2lvst2_X
+}