summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorusrmusicman2019-10-22 21:49:53 -0400
committerusrmusicman2019-10-22 21:49:53 -0400
commit1534a63f01e48518972154720a919d5463b337ab (patch)
tree3ca9bee5cdd49a8c266d274d9101fc65396ea8d8
parent8ffa5562a0099087a38214267fb95f191139d2a4 (diff)
downloadaur-1534a63f01e48518972154720a919d5463b337ab.tar.gz
Update linvst3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--w2lvst329
3 files changed, 10 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb56216d7397..2112ab5366dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = linvst3
pkgdesc = enables Windows vst3's to be used as Linux vst's in Linux vst capable DAW's
- pkgver = 1.7.0
- pkgrel = 3
+ pkgver = 1.7.2
+ pkgrel = 1
url = https://github.com/osxmidi/LinVst
arch = x86_64
makedepends = git
@@ -15,8 +15,8 @@ pkgbase = linvst3
depends = expat
depends = gtkmm3
depends = sqlite
- source = https://github.com/osxmidi/LinVst3/releases/download/1.7/LinVst3-1.7-Debian-Stretch.zip
- source = w2lvst3
+ source = https://github.com/osxmidi/LinVst3/releases/download/1.7/LinVst3-1.7.2-Debian-Stretch.zip
+ source = https://github.com/usrmusicman/ArchStudioUtils/archive/2.4.zip
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2bfeb3aa3dad..f535b4f2a53f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
pkgname=linvst3
-pkgver=1.7.0
-_pkgver=1.7
-pkgrel=3
+pkgver=1.7.2
+pkgver_w2lvst3=2.4
+pkgrel=1
pkgdesc="enables Windows vst3's to be used as Linux vst's in Linux vst capable DAW's"
arch=('x86_64')
url="https://github.com/osxmidi/LinVst"
depends=('wine' 'freetype2' 'xcb-util' 'xcb-util-cursor' 'xcb-util-keysyms' 'libxkbcommon-x11' 'libx11' 'expat' 'gtkmm3' 'sqlite')
makedepends=('git')
-source=("https://github.com/osxmidi/LinVst3/releases/download/${_pkgver}/LinVst3-${_pkgver}-Debian-Stretch.zip" 'w2lvst3')
+source=("https://github.com/osxmidi/LinVst3/releases/download/1.7/LinVst3-${pkgver}-Debian-Stretch.zip"
+ "https://github.com/usrmusicman/ArchStudioUtils/archive/${pkgver_w2lvst3}.zip")
sha256sums=('SKIP'
'SKIP')
@@ -19,5 +20,5 @@ package() {
for file in *.exe; do
install -Dm755 $file $pkgdir/usr/bin/$file
done
- install -Dm755 $srcdir/w2lvst3 $pkgdir/usr/bin/w2lvst3
+ install -Dm755 $srcdir/ArchStudioUtils-$pkgver/w2lvst2 $pkgdir/usr/bin/w2lvst2
}
diff --git a/w2lvst3 b/w2lvst3
deleted file mode 100644
index 5aae701e59b0..000000000000
--- a/w2lvst3
+++ /dev/null
@@ -1,29 +0,0 @@
-#!/usr/bin/python3
-
-# Maintainer: Alexander Mcmillan <linuxguy93@gmail.com>
-
-# Imported Modules
-import os # native OS support
-import shutil # high-level file operations support
-import glob # support globbing *
-import sys # import sytem functions
-
-# Golbal Variables
-linvstfileso="/usr/bin/linvst3.so" # the linvst3.so bridge file for the linvst3 bridge
-homedir=os.path.expanduser("~") # expand the current users home directory /home/<user>
-vstdir=(homedir + "/" + ".vst3" + "/" + "windows-bridged" + "/") # DAW scanned VST directory
-currentdir=os.getcwd() + "/" # get the current work directory
-
-# Executable Code
-print ("\033[1;38m" + "Start LinVst3 Bridge Creation" + "\033[0m") # print start message
-os.makedirs(vstdir, exist_ok=True) # create a /home/<user>/<vstdir> directory
-for i in glob.glob("*.vst3"): # check for all files with a .vst3 extension
- vstname, extdll=os.path.splitext(i) # split the filename from its extension, store each value in a seperate variable
- extso=(".so") # the destination exstension .so for Linux DAW compatibility
- shutil.copy2(linvstfileso, vstname + extso) # copy the linvst.so bridge file to match the vstname .vst3 file. example: plugin.vst3, plugin.so
- print("\033[1;33m" + vstname + ": " + "\033[1;36m" + "Link Generated..." + "\033[0m") # print the .so link to be generated
- if os.path.islink(vstdir + vstname + extso): # Check if link exists
- os.remove(vstdir + vstname + extso) # remove old link for vst bridge
- os.symlink(currentdir + vstname + extso, vstdir + vstname + extso) # generate link for vst bridge
- else:
- os.symlink(currentdir + vstname + extso, vstdir + vstname + extso) # generate link for vst bridge