summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom van der Lee2015-06-09 21:27:04 +0200
committerTom van der Lee2015-06-09 21:32:11 +0200
commit2ab5e184e796c3fc1d561d008bfcf4be516e71ea (patch)
tree487f2c12747bdfa1408ce4c40b1c1dd9e451ad65
downloadaur-2ab5e184e796c3fc1d561d008bfcf4be516e71ea.tar.gz
Added liquidprompt to aur4
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD28
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..85a1b90ebb82
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = liquidprompt
+ pkgdesc = A useful adaptive prompt for Bash & Zsh
+ pkgver = 1.9
+ pkgrel = 2
+ url = https://github.com/nojhan/liquidprompt
+ arch = any
+ license = AGPLv3
+ depends = ncurses
+ depends = grep
+ depends = gawk
+ depends = sed
+ depends = procps-ng
+ depends = coreutils
+ optdepends = acpi: Battery and temperature status
+ optdepends = lm_sensors: Temperature status
+ conflicts = liquidprompt-git
+ conflicts = liquidprompt-devel-git
+ source = https://github.com/nojhan/liquidprompt/archive/v_1.9.tar.gz
+ sha256sums = 4751665b6dbf37517ba8e7b6af067369937006b60ca23fc320fd5416b1a065fd
+
+pkgname = liquidprompt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee5ac83a2ecd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Tom van der Lee <t0m.vd.l33@gmail.com>
+pkgname=liquidprompt
+pkgver=1.9
+pkgrel=2
+pkgdesc="A useful adaptive prompt for Bash & Zsh"
+arch=("any")
+url="https://github.com/nojhan/liquidprompt"
+license=("AGPLv3")
+conflicts=("liquidprompt-git"
+ "liquidprompt-devel-git")
+depends=("ncurses"
+ "grep"
+ "gawk"
+ "sed"
+ "procps-ng"
+ "coreutils")
+optdepends=("acpi: Battery and temperature status"
+ "lm_sensors: Temperature status")
+source=(https://github.com/nojhan/liquidprompt/archive/v_$pkgver.tar.gz)
+sha256sums=('4751665b6dbf37517ba8e7b6af067369937006b60ca23fc320fd5416b1a065fd')
+
+package() {
+ cd "$pkgname-v_$pkgver"
+ install -Dm755 liquidprompt "$pkgdir/usr/bin/liquidprompt"
+ install -Dm644 liquidpromptrc-dist "$pkgdir/etc/liquidpromptrc"
+}
+
+# vim: set ts=8 sw=8 tw=0 noet :