summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302018-04-23 01:48:09 +0200
committerM0Rf302018-04-23 01:48:09 +0200
commit277c2387468bcad5bb1a501009b0c4bc41ab3462 (patch)
tree4d6d75fa7c7048c63baf3854e5589da44ecbb9fe
parentc8c0bd830689e035ecf10ff86524c1c3608fcbbd (diff)
downloadaur-277c2387468bcad5bb1a501009b0c4bc41ab3462.tar.gz
liquidsoap: fixing at last
-rw-r--r--.SRCINFO6
-rw-r--r--PACKAGES30
-rw-r--r--PKGBUILD14
3 files changed, 19 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f521825be13..5f220919a866 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,6 +12,7 @@ pkgbase = liquidsoap
makedepends = git
makedepends = ladspa
makedepends = libxml-perl
+ makedepends = ocaml-camomile
makedepends = ocaml-gd4o
makedepends = ocaml-ocamlsdl
makedepends = ocaml-pcre
@@ -34,10 +35,7 @@ pkgbase = liquidsoap
depends = liblo
depends = libmad
depends = libxpm
- depends = ocaml-ffmpeg
- depends = ocaml-ogg
depends = openssl
- depends = portaudio
depends = sdl_image
depends = sdl_ttf
depends = soundtouch
@@ -50,7 +48,7 @@ pkgbase = liquidsoap
source = liquidsoap.service
source = liquidsoap.tmpfilesd
md5sums = SKIP
- md5sums = a69d72938d424cdeb88f73a32d6a78cb
+ md5sums = 039d14f134c5606cec163fcc1a7c7dc6
md5sums = 762d6607ff0889e34b8c874970b38bc9
md5sums = f9106e5c42cabc21c4c8464d9b1ad63e
diff --git a/PACKAGES b/PACKAGES
index b02bcb22e83c..1aad61bfa7ad 100644
--- a/PACKAGES
+++ b/PACKAGES
@@ -22,18 +22,18 @@ ocaml-cry
ocaml-ao
# Portaudio is a portable audio library with both input and output.
-ocaml-portaudio
+#ocaml-portaudio
# ALSA is only for LINUX, and is sometimes not working.
#ocaml-alsa
# PulseAudio is a cross-plateform audio sound server. It is intended to
# be a single replacement for sound support under linux, windows or OSX.
-ocaml-pulseaudio
+#ocaml-pulseaudio
# JACK is an audio connection kit, designed for low latency
# and easy communication between audio applications.
-ocaml-bjack
+#ocaml-bjack
# Gstreamer is a library for constructing graphs of media-handling components.
# It is currently used to provide audio and video encoding and decoding
@@ -45,7 +45,7 @@ ocaml-gstreamer
# ============================================================================
# MAD is for MP3 decoding.
-ocaml-mad
+#ocaml-mad
# TAGLIB is for MP3 ID3 tag reading
ocaml-taglib
@@ -56,11 +56,8 @@ ocaml-lame
# SHINE is for fixed-point MP3 encoding.
#ocaml-shine
-# AACPLUS is for AAC+ encoding.
-#ocaml-aacplus
-
# OGG is for ogg/vorbis and ogg/theora encoding and decoding
-#ocaml-ogg
+ocaml-ogg
# VORBIS is for ogg/vorbis encoding and decoding.
# you need ocaml-ogg to enable ocaml-vorbis.
@@ -79,18 +76,11 @@ ocaml-theora
# you need ocaml-ogg to enable ocaml-opus
ocaml-opus
-# SCHROEDINGER is for ogg/dirac encoding and decoding
-# you need ocaml-ogg to enable ocaml-schroedinger
-ocaml-schroedinger
-
-# VOAACENC is for AAC encoding.
-#ocaml-voaacenc
-
# FDK-AAC is for AAC and AAC+ encoding
-ocaml-fdkaac
+#ocaml-fdkaac
# FAAD for AAC decoding.
-ocaml-faad
+#ocaml-faad
# FLAC is for flac, native and/or ogg (if using ocaml-ogg)
# format decoding and encoding.
@@ -117,7 +107,7 @@ ocaml-samplerate
# is very efficient and has a quality setting for
# tweaking load vs. quality of the conversion.
# It is the recommended module to use with video
-ocaml-gavl
+#ocaml-gavl
# FFMPEG is currently only used to convert from
# and to many formats.
@@ -131,7 +121,7 @@ ocaml-gavl
# ============================================================================
# DSSI is a standard for synthesizer plugins
-ocaml-dssi
+#ocaml-dssi
# ============================================================================
# Various modules
@@ -146,7 +136,7 @@ ocaml-lastfm
# A library supporting the OSC protocol to have external controls
# such as faders
-ocaml-lo
+#ocaml-lo
# ============================================================================
# Finally, the mandatory lib dtools, duppy and liquidsoap...
diff --git a/PKGBUILD b/PKGBUILD
index c5d9bf2b0efc..33fa28866fab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@ pkgdesc="A swiss-army knife for multimedia streaming, notably used for netradios
arch=('i686' 'x86_64')
url="http://savonet.sourceforge.net/"
license=('GPL')
-depends=('faad2' 'ffmpeg' 'fluidsynth' 'gavl' 'gd' 'giflib' 'gst-plugins-bad' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-ugly' 'libao' 'libfdk-aac' 'liblo' 'libmad' 'libxpm' 'ocaml-ffmpeg' 'ocaml-ogg' 'openssl' 'portaudio' 'sdl_image' 'sdl_ttf' 'soundtouch' 'taglib')
-makedepends=('dssi' 'frei0r-plugins' 'git' 'ladspa' 'libxml-perl' 'ocaml-gd4o' 'ocaml-ocamlsdl' 'ocaml-pcre' 'ocaml-ssl' 'ocaml-xmlm' 'ocaml-yojson' 'perl-xml-dom')
+depends=('faad2' 'ffmpeg' 'fluidsynth' 'gavl' 'gd' 'giflib' 'gst-plugins-bad' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-ugly' 'libao' 'libfdk-aac' 'liblo' 'libmad' 'libxpm' 'openssl' 'sdl_image' 'sdl_ttf' 'soundtouch' 'taglib')
+makedepends=('dssi' 'frei0r-plugins' 'git' 'ladspa' 'libxml-perl' 'ocaml-camomile' 'ocaml-gd4o' 'ocaml-ocamlsdl' 'ocaml-pcre' 'ocaml-ssl' 'ocaml-xmlm' 'ocaml-yojson' 'perl-xml-dom')
source=("$pkgname-$pkgver-full::git+https://github.com/savonet/liquidsoap-full"
PACKAGES
$pkgname.service
@@ -29,8 +29,8 @@ prepare() {
build() {
cd $srcdir/$pkgname-$pkgver-full
- ./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc --without-user --without-group --disable-camomile --disable-oss
- make all && make doc
+ ./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc --without-user --without-group --disable-oss --disable-portaudio
+ SED="/usr/bin/sed" make all && make doc
}
package() {
@@ -44,6 +44,6 @@ package() {
}
md5sums=('SKIP'
- 'a69d72938d424cdeb88f73a32d6a78cb'
- '762d6607ff0889e34b8c874970b38bc9'
-'f9106e5c42cabc21c4c8464d9b1ad63e')
+ '039d14f134c5606cec163fcc1a7c7dc6'
+ '762d6607ff0889e34b8c874970b38bc9'
+ 'f9106e5c42cabc21c4c8464d9b1ad63e')