summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Boiano2018-08-28 11:31:53 +0200
committerGianluca Boiano2018-08-28 11:31:53 +0200
commit3006f13b651ff5aa7a8ff808ce325d18f06e0cbb (patch)
tree6ecdfb58d5e4f96ea7ae8da75e08b9eb8ee3d387
parent0c29909826fc4a19c5962a34d38abcc6a41c1dcd (diff)
downloadaur-3006f13b651ff5aa7a8ff808ce325d18f06e0cbb.tar.gz
liquidsoap: added some features and cleanup of deps
-rw-r--r--.SRCINFO8
-rw-r--r--PACKAGES12
-rw-r--r--PKGBUILD8
3 files changed, 14 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00fd2569819d..565cd9baa3e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = liquidsoap
pkgdesc = A swiss-army knife for multimedia streaming, notably used for netradios and webtvs
pkgver = 1.3.3
- pkgrel = 3
+ pkgrel = 4
url = http://savonet.sourceforge.net/
install = liquidsoap.install
arch = i686
arch = x86_64
license = GPL
makedepends = camlp4
- makedepends = dssi
- makedepends = frei0r-plugins
makedepends = git
makedepends = ladspa
makedepends = libxml-perl
@@ -21,9 +19,11 @@ pkgbase = liquidsoap
makedepends = ocaml-xmlm
makedepends = ocaml-yojson
makedepends = perl-xml-dom
+ depends = dssi
depends = faad2
depends = ffmpeg
depends = fluidsynth
+ depends = frei0r-plugins
depends = gavl
depends = gd
depends = giflib
@@ -50,7 +50,7 @@ pkgbase = liquidsoap
source = liquidsoap.service
source = liquidsoap.tmpfilesd
md5sums = SKIP
- md5sums = bafeb8cb204a8c3368a81778e03cfcc5
+ md5sums = 9dda84bbb09ed802cda1f417221a4f4c
md5sums = 762d6607ff0889e34b8c874970b38bc9
md5sums = f9106e5c42cabc21c4c8464d9b1ad63e
diff --git a/PACKAGES b/PACKAGES
index 864373693dc1..a98071069796 100644
--- a/PACKAGES
+++ b/PACKAGES
@@ -54,7 +54,7 @@ ocaml-taglib
ocaml-lame
# SHINE is for fixed-point MP3 encoding.
-#ocaml-shine
+ocaml-shine
# OGG is for ogg/vorbis and ogg/theora encoding and decoding
ocaml-ogg
@@ -80,7 +80,7 @@ ocaml-opus
ocaml-fdkaac
# FAAD for AAC decoding.
-#ocaml-faad
+ocaml-faad
# FLAC is for flac, native and/or ogg (if using ocaml-ogg)
# format decoding and encoding.
@@ -111,17 +111,17 @@ ocaml-gavl
# FFMPEG is currently only used to convert from
# and to many formats.
-#ocaml-ffmpeg
+ocaml-ffmpeg
# Frei0r is a minimalistic plugin API for video sources and filters.
-#ocaml-frei0r
+ocaml-frei0r
# ============================================================================
# Sound synthesis
# ============================================================================
# DSSI is a standard for synthesizer plugins
-#ocaml-dssi
+ocaml-dssi
# ============================================================================
# Various modules
@@ -136,7 +136,7 @@ ocaml-lastfm
# A library supporting the OSC protocol to have external controls
# such as faders
-#ocaml-lo
+ocaml-lo
# ============================================================================
# Finally, the mandatory lib dtools, duppy and liquidsoap...
diff --git a/PKGBUILD b/PKGBUILD
index 918011f59ca9..10ae3cef136d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=liquidsoap
pkgver=1.3.3
-pkgrel=3
+pkgrel=4
pkgdesc="A swiss-army knife for multimedia streaming, notably used for netradios and webtvs"
arch=('i686' 'x86_64')
url="http://savonet.sourceforge.net/"
license=('GPL')
-depends=('faad2' 'ffmpeg' 'fluidsynth' 'gavl' 'gd' 'giflib' 'gst-plugins-bad' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-ugly' 'libao' 'libfdk-aac' 'liblo' 'libmad' 'libxpm' 'ocaml-camomile' 'openssl' 'sdl_image' 'sdl_ttf' 'soundtouch' 'taglib')
-makedepends=('camlp4' 'dssi' 'frei0r-plugins' 'git' 'ladspa' 'libxml-perl' 'ocaml-findlib' 'ocaml-gd4o' 'ocaml-ocamlsdl' 'ocaml-pcre' 'ocaml-ssl' 'ocaml-xmlm' 'ocaml-yojson' 'perl-xml-dom')
+depends=('dssi' 'faad2' 'ffmpeg' 'fluidsynth' 'frei0r-plugins' 'gavl' 'gd' 'giflib' 'gst-plugins-bad' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-ugly' 'libao' 'libfdk-aac' 'liblo' 'libmad' 'libxpm' 'ocaml-camomile' 'openssl' 'sdl_image' 'sdl_ttf' 'soundtouch' 'taglib')
+makedepends=('camlp4' 'git' 'ladspa' 'libxml-perl' 'ocaml-findlib' 'ocaml-gd4o' 'ocaml-ocamlsdl' 'ocaml-pcre' 'ocaml-ssl' 'ocaml-xmlm' 'ocaml-yojson' 'perl-xml-dom')
source=("$pkgname-$pkgver-full::git+https://github.com/savonet/liquidsoap-full"
PACKAGES
$pkgname.service
@@ -44,6 +44,6 @@ package() {
}
md5sums=('SKIP'
- 'bafeb8cb204a8c3368a81778e03cfcc5'
+ '9dda84bbb09ed802cda1f417221a4f4c'
'762d6607ff0889e34b8c874970b38bc9'
'f9106e5c42cabc21c4c8464d9b1ad63e')