summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302019-12-15 15:15:48 +0100
committerM0Rf302019-12-15 15:15:48 +0100
commit5c0f954ba7aaef1d4a22506704b6787c7ec304f8 (patch)
tree4474bf881a7f058ac945a7d56d494f76f39b9e0b
parent9bde0e4fc79a309791acbda91add7e7f8b779292 (diff)
downloadaur-5c0f954ba7aaef1d4a22506704b6787c7ec304f8.tar.gz
liquidsoap: finally builds
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD29
2 files changed, 19 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b718a2f5e0c..215997d95d28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = liquidsoap
pkgdesc = A swiss-army knife for multimedia streaming, notably used for netradios and webtvs
pkgver = 1.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://www.liquidsoap.info
install = liquidsoap.install
arch = i686
@@ -35,7 +35,7 @@ pkgbase = liquidsoap
depends = ocaml-gd4o
depends = ocaml-gstreamer
depends = ocaml-inotify
- depends = ocaml-yojson
+ depends = ocaml-yojson-git
depends = ocaml-ladspa
depends = ocaml-lame-git
depends = ocaml-lastfm
diff --git a/PKGBUILD b/PKGBUILD
index c4f8de946f7d..ee4bdf2e5f5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=liquidsoap
pkgver=1.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="A swiss-army knife for multimedia streaming, notably used for netradios and webtvs"
arch=('i686' 'x86_64')
url="https://www.liquidsoap.info"
@@ -25,7 +25,7 @@ depends=('fluidsynth' 'giflib' 'gst-plugins-good' 'gst-plugins-ugly'
'ocaml-gd4o'
'ocaml-gstreamer'
'ocaml-inotify'
- 'ocaml-yojson'
+ 'ocaml-yojson-git'
'ocaml-ladspa'
'ocaml-lame-git'
'ocaml-lastfm'
@@ -50,29 +50,34 @@ depends=('fluidsynth' 'giflib' 'gst-plugins-good' 'gst-plugins-ugly'
)
makedepends=('camlp4' 'libxml-perl' 'ocaml-findlib' 'ocaml-menhir' 'ocaml-pcre' 'ocaml-sedlex-git' 'perl-xml-dom')
optdepends=('curl')
+options=('!makeflags')
source=("https://github.com/savonet/liquidsoap/releases/download/$pkgver/$pkgname-$pkgver.tar.bz2"
$pkgname.service
$pkgname.tmpfilesd
)
install=$pkgname.install
-options=(!makeflags)
conflicts=('liquidsoap-git' 'liquidsoap-full')
-build() {
- cd $srcdir/$pkgname-$pkgver
-
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+ sed -i "s|bashcompdir=|bashcompdir=${pkgdir//\//\\/}|g" configure.ac
+ sed -i "s|emacsdir=|emacsdir=${pkgdir//\//\\/}|g" configure.ac
+ ./bootstrap
./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc \
- --without-user --without-group \
- --disable-oss
+ --without-user --without-group \
+ --disable-oss
+}
- make all && make doc
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make all
}
package() {
cd $srcdir/$pkgname-$pkgver
- make DESTDIR="$pkgdir/" datadir="$pkgdir/usr/share/" mandir="$pkgdir/usr/share/man/" localstatedir="$pkgdir/var" bindir="$pkgdir/usr/bin/" libdir="$pkgdir/usr/lib/" sysconfdir="$pkgdir/etc/" install
+ make DESTDIR="$pkgdir" datadir="$pkgdir/usr/share/" mandir="$pkgdir/usr/share/man/" localstatedir="$pkgdir/var" bindir="$pkgdir/usr/bin/" libdir="$pkgdir/usr/lib/" sysconfdir="$pkgdir/etc/" install
# Install systemd unit
install -Dm0644 "$srcdir/$pkgname.service" "$pkgdir/usr/lib/systemd/system/liquidsoap@.service"
@@ -81,5 +86,5 @@ package() {
}
md5sums=('04b7e8fa1f49236df86bc48f386e8f40'
- '762d6607ff0889e34b8c874970b38bc9'
-'f9106e5c42cabc21c4c8464d9b1ad63e')
+ '762d6607ff0889e34b8c874970b38bc9'
+ 'f9106e5c42cabc21c4c8464d9b1ad63e')