summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRiley Trautman2015-10-20 14:33:16 -0500
committerRiley Trautman2015-10-20 14:33:16 -0500
commit3034f753ca12979c4d2d7f5b13178759197c59b8 (patch)
tree1d7983c9c77d7f1edd4a5c5a1f13a003f5125854
parentcb73bbf0072735054c0a8abe64e88237567b9f07 (diff)
downloadaur-3034f753ca12979c4d2d7f5b13178759197c59b8.tar.gz
Add liri-player build dep
-rw-r--r--PKGBUILD29
1 files changed, 28 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed9fc959ba08..10f90766d077 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,8 +14,12 @@ provides=("$_pkgname" "$pkgname")
conflicts=("$_pkgname")
install=$pkgname.install
source=("$pkgname::git+https://github.com/liri-browser/liri-browser.git"
+ "liriplayer::git+https://github.com/pierremtb/liri-player.git"
+ "qmlvlc::git+https://github.com/RSATom/QmlVlc.git"
+ "yalibvlcwrapper::git+https://github.com/RSATom/ya-libvlc-wrapper.git"
+ "libvlcsdk::git+https://github.com/RSATom/libvlc-sdk.git"
"liri-browser.sh" "liri-browser.desktop" "$pkgname.install")
-sha256sums=("SKIP" "SKIP" "SKIP" "SKIP")
+sha256sums=("SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP")
pkgver() {
cd "$pkgname"
@@ -24,6 +28,29 @@ pkgver() {
}
build() {
+ pushd $(pwd) >> /dev/null
+
+ cd "$srcdir/$pkgname"
+ git submodule init
+ git config submodule.dependencies/liri-player.url "$srcdir/liriplayer"
+ git submodule update
+
+ cd "dependencies/liri-player"
+ git submodule init
+ git config submodule.dependencies/QmlVlc.url "$srcdir/qmlvlc"
+ git submodule update
+
+ cd "dependencies/QmlVlc"
+ git submodule init
+ git config submodule.libvlc_wrapper.url "$srcdir/yalibvlcwrapper"
+ git submodule update
+
+ cd "libvlc_wrapper"
+ git submodule init
+ git config submodule.libvlc-sdk.url "$srcdir/libvlcsdk"
+ git submodule update
+
+ popd >> /dev/null
mkdir -p build
cd build
qmake "$srcdir/$pkgname"