summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPier Luigi Fiorini2017-01-01 16:32:33 +0100
committerPier Luigi Fiorini2017-01-01 16:32:33 +0100
commit806c2e5f0f5183c317bc385c64aae002964c3a63 (patch)
tree9efd0d4092f6aa4ad4aa7ee333ca1ce615f4ac53
parent14dbff1aaff0bdd9d924ca86e5e9bef7fe0ba6de (diff)
downloadaur-806c2e5f0f5183c317bc385c64aae002964c3a63.tar.gz
Update to latest version
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD78
-rw-r--r--liri-browser-git.install35
-rw-r--r--liri-browser.desktop11
-rw-r--r--liri-browser.install35
-rw-r--r--liri-browser.sh9
6 files changed, 43 insertions, 156 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2423678d2c6b..e3c996b2e075 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,24 @@
# Generated by mksrcinfo v8
-# Fri Mar 4 23:47:36 UTC 2016
+# Sun Jan 1 15:31:58 UTC 2017
pkgbase = liri-browser-git
- pkgdesc = A Web Browser using the QML Material framework from the Papyros Project
- pkgver = 0.3.r243.gc39f696
+ pkgdesc = Liri Browser
+ pkgver = 20161012.664b549
pkgrel = 1
- url = https://github.com/liri-project/liri-browser
- install = liri-browser.install
+ url = http://liri.io
arch = i686
arch = x86_64
- license = GPLv3
+ arch = armv6h
+ arch = armv7h
+ groups = liri-git
+ license = GPL3
makedepends = git
- depends = qt5-base
- depends = qt5-webengine
- depends = qt5-multimedia
- depends = qml-material-git
+ depends = fluid-git
+ depends = slime-engine-git
provides = liri-browser
conflicts = liri-browser
- source = liri-browser::git+https://github.com/liri-project/liri-browser.git
- source = liri-browser.sh
- source = liri-browser.desktop
- source = liri-browser.install
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
+ replaces = liri-browser
+ source = browser::git://github.com/lirios/browser.git#branch=master
+ md5sums = SKIP
pkgname = liri-browser-git
diff --git a/PKGBUILD b/PKGBUILD
index ab62d9576326..2d1beb405572 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,59 +1,41 @@
-# Maintainer: Riley Trautman <asonix.dev@gmail.com>
+# Maintainer: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
-_pkgname=liri-browser
-pkgname=${_pkgname}-git
-pkgver=0.3.r243.gc39f696
+pkgname=liri-browser-git
+pkgver=20161012.664b549
pkgrel=1
-pkgdesc="A Web Browser using the QML Material framework from the Papyros Project"
-arch=("i686" "x86_64")
-url="https://github.com/liri-project/liri-browser"
-license=("GPLv3")
-depends=("qt5-base" "qt5-webengine" "qt5-multimedia" "qml-material-git")
-makedepends=("git")
-provides=("${_pkgname}")
-conflicts=("${_pkgname}")
-install=${_pkgname}.install
-source=("${_pkgname}::git+https://github.com/liri-project/liri-browser.git"
-"liri-browser.sh" "liri-browser.desktop" "liri-browser.install")
-sha256sums=("SKIP" "SKIP" "SKIP" "SKIP")
+pkgdesc="Liri Browser"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url='https://liri.io'
+license=('GPL3')
+depends=('fluid-git' 'slime-engine-git')
+makedepends=('git')
+conflicts=('liri-browser')
+replaces=('liri-browser')
+provides=('liri-browser')
+groups=('liri-git')
+
+_gitroot="git://github.com/lirios/browser.git"
+_gitbranch=master
+_gitname=browser
+source=(${_gitname}::${_gitroot}#branch=${_gitbranch})
+md5sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
- # cutting off 'foo-' prefix that presents in the git tag
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd ${srcdir}/${_gitname}
+ echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git log -1 --format="%h")"
}
-build() {
- cd "${_pkgname}"
- qmake "liri-browser.pro"
- make
+prepare() {
+ mkdir -p build
}
-package() {
- cd "${_pkgname}"
- make INSTALL_ROOT="$pkgdir" install
-
- mkdir -p "$pkgdir"/usr/bin
- mkdir -p "$pkgdir"/usr/share/applications
-
- for i in 16x16 22x22 32x32 48x48 64x64 128x128 256x256; do
- install -Dm644 "$srcdir"/"${_pkgname}"/icons/liri-browser.png \
- "$pkgdir"/usr/share/icons/hicolor/$i/apps/liri-browser.png
- done
- install -m755 ../liri-browser.sh \
- "$pkgdir"/usr/bin/liri-browser
- install -m755 ../liri-browser.desktop \
- "$pkgdir"/usr/share/applications/liri-browser.desktop
-}
-
-# Additional functions to generate a changelog
-
-changelog() {
- cd "${_pkgname}"
- git log $1..HEAD --no-merges --format=" * %s"
+build() {
+ cd build
+ qmake CONFIG+=QTWEBENGINE_ENABLED ../${_gitname}
+ make
}
-gitref() {
- cd "${_pkgname}"
- git rev-parse HEAD
+package() {
+ cd build
+ make INSTALL_ROOT="${pkgdir}" install
}
diff --git a/liri-browser-git.install b/liri-browser-git.install
deleted file mode 100644
index cd3b519abf28..000000000000
--- a/liri-browser-git.install
+++ /dev/null
@@ -1,35 +0,0 @@
-# Colored makepkg-like functions
-msg_blue() {
- printf "${blue}==>${bold} $1${all_off}\n"
-}
-
-note() {
- printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
-}
-
-all_off="$(tput sgr0)"
-bold="${all_off}$(tput bold)"
-blue="${bold}$(tput setaf 4)"
-yellow="${bold}$(tput setaf 3)"
-
-_update() {
- msg_blue "Updating desktop MIME database..."
- update-desktop-database -q
-
- msg_blue "Updating icon cache.."
- xdg-icon-resource forceupdate --theme hicolor &>/dev/null
-}
-
-post_install() {
- _update
- note "Custom flags should be put directly in: ~/.config/liri-flags.conf"
- note "The launcher is called: 'liri-browser'"
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- _update
-}
diff --git a/liri-browser.desktop b/liri-browser.desktop
deleted file mode 100644
index f3ff434b2adc..000000000000
--- a/liri-browser.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Name=Liri Browser
-Comment=Browse the Internet
-Keywords=internet;browser;explore;web;
-GenericName=Web Browser
-Exec=liri-browser
-Icon=liri-browser
-Terminal=false
-StartupNotify=true
-Type=Application
-Categories=Network;Internet;QT;QML;WebBrowser;
diff --git a/liri-browser.install b/liri-browser.install
deleted file mode 100644
index cd3b519abf28..000000000000
--- a/liri-browser.install
+++ /dev/null
@@ -1,35 +0,0 @@
-# Colored makepkg-like functions
-msg_blue() {
- printf "${blue}==>${bold} $1${all_off}\n"
-}
-
-note() {
- printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
-}
-
-all_off="$(tput sgr0)"
-bold="${all_off}$(tput bold)"
-blue="${bold}$(tput setaf 4)"
-yellow="${bold}$(tput setaf 3)"
-
-_update() {
- msg_blue "Updating desktop MIME database..."
- update-desktop-database -q
-
- msg_blue "Updating icon cache.."
- xdg-icon-resource forceupdate --theme hicolor &>/dev/null
-}
-
-post_install() {
- _update
- note "Custom flags should be put directly in: ~/.config/liri-flags.conf"
- note "The launcher is called: 'liri-browser'"
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- _update
-}
diff --git a/liri-browser.sh b/liri-browser.sh
deleted file mode 100644
index 7162c800b66a..000000000000
--- a/liri-browser.sh
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/bash
-
-# Allow users to override command-line options
-if [[ -f ~/.config/liri-flags.conf ]]; then
- LIRI_USER_FLAGS="$(cat ~/.config/liri-flags.conf)"
-fi
-
-# Launch
-exec /opt/liri-browser-build/liri-browser $LIRI_USER_FLAGS $@