summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRiley Trautman2015-09-13 15:56:38 -0500
committerRiley Trautman2015-09-13 15:56:38 -0500
commitc178cd3ffd5c5d0b576a8ee90ec1c4a4c327ebf9 (patch)
tree25c114d48588c27023193f4053f5841263d2ed38
parentdbc00c9b4be7a6f3b307eb8617fb2cbd16a9c349 (diff)
downloadaur-c178cd3ffd5c5d0b576a8ee90ec1c4a4c327ebf9.tar.gz
added install file
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--liri-browser-git.install35
3 files changed, 40 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d75f3723bd5..60ca92f7017b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,6 +16,8 @@ pkgbase = liri-browser-git
source = liri-browser-git::git+https://github.com/liri-browser/liri-browser.git
source = liri-browser
source = liri-browser.desktop
+ source = liri-browser-git.install
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 528fbcf24c7b..f7eb1d0b263f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,8 @@ makedepends=("git")
provides=("$_pkgname" "$pkgname")
conflicts=("$_pkgname")
source=("$pkgname::git+https://github.com/liri-browser/liri-browser.git"
- "liri-browser" "liri-browser.desktop")
-sha256sums=("SKIP" "SKIP" "SKIP")
+ "liri-browser" "liri-browser.desktop" "$pkgname.install")
+sha256sums=("SKIP" "SKIP" "SKIP" "SKIP")
pkgver() {
cd "$pkgname"
@@ -38,7 +38,7 @@ package() {
for i in 16x16 22x22 32x32 48x48 64x64 128x128 256x256; do
install -Dm644 "$srcdir"/"$pkgname"/icons/liri-browser.png \
- "$pkgdir"/usr/share/icons/hicolor/$i/liri-browser.png
+ "$pkgdir"/usr/share/icons/hicolor/$i/apps/liri-browser.png
done
install -m755 ../liri-browser \
"$pkgdir"/usr/bin/liri-browser
diff --git a/liri-browser-git.install b/liri-browser-git.install
new file mode 100644
index 000000000000..cd3b519abf28
--- /dev/null
+++ b/liri-browser-git.install
@@ -0,0 +1,35 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+_update() {
+ msg_blue "Updating desktop MIME database..."
+ update-desktop-database -q
+
+ msg_blue "Updating icon cache.."
+ xdg-icon-resource forceupdate --theme hicolor &>/dev/null
+}
+
+post_install() {
+ _update
+ note "Custom flags should be put directly in: ~/.config/liri-flags.conf"
+ note "The launcher is called: 'liri-browser'"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ _update
+}