summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRiley Trautman2015-10-16 14:44:43 -0500
committerRiley Trautman2015-10-16 14:44:43 -0500
commit1bdfba3fafbaf76b9325141c75ecbd4b0ec76dda (patch)
treecb82a25d0495c93518a49dbfc9ab2e8b17c2ac6b
downloadaur-1bdfba3fafbaf76b9325141c75ecbd4b0ec76dda.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD86
-rw-r--r--liri-player-git.install35
-rw-r--r--liri-player.desktop11
4 files changed, 162 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..748c748daadb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = liri-player-git
+ pkgdesc = A Web player using the QML Material framework from the Papyros Project
+ pkgver = git
+ pkgrel = 1
+ url = https://github.com/pierremtb/liri-player
+ install = liri-player-git.install
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ makedepends = git
+ depends = qt5-base
+ depends = qml-material
+ provides = liri-player
+ provides = liri-player-git
+ conflicts = liri-player
+ source = liri-player-git::git+https://github.com/pierremtb/liri-player.git
+ source = qmlvlc::git+https://github.com/RSATom/QmlVlc.git
+ source = yalibvlcwrapper::git+https://github.com/RSATom/ya-libvlc-wrapper.git
+ source = libvlcsdk::git+https://github.com/RSATom/libvlc-sdk.git
+ source = liri-player.desktop
+ source = liri-player-git.install
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = liri-player-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b15081b4ded6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,86 @@
+# Maintainer: Riley Trautman <asonix.dev@gmail.com>
+
+_pkgname=liri-player
+pkgname=$_pkgname-git
+pkgver=git
+pkgrel=1
+pkgdesc="A Web player using the QML Material framework from the Papyros Project"
+arch=("i686" "x86_64")
+url="https://github.com/pierremtb/liri-player"
+license=("GPLv3")
+depends=("qt5-base" "qml-material")
+makedepends=("git")
+provides=("$_pkgname" "$pkgname")
+conflicts=("$_pkgname")
+install=$pkgname.install
+source=("$pkgname::git+https://github.com/pierremtb/liri-player.git"
+ "qmlvlc::git+https://github.com/RSATom/QmlVlc.git"
+ "yalibvlcwrapper::git+https://github.com/RSATom/ya-libvlc-wrapper.git"
+ "libvlcsdk::git+https://github.com/RSATom/libvlc-sdk.git"
+ "liri-player.desktop" "$pkgname.install")
+sha256sums=("SKIP" "SKIP" "SKIP" "SKIP" "SKIP" "SKIP")
+
+pkgver() {
+ cd "$pkgname"
+ # cutting off 'foo-' prefix that presents in the git tag
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ pushd $(pwd) >> /dev/null
+
+ cd "$srcdir/$pkgname"
+ git submodule init
+ git config submodule.dependencies/QmlVlc.url "$srcdir/qmlvlc"
+ git submodule update
+
+ cd "dependencies/QmlVlc"
+ git submodule init
+ git config submodule.libvlc_wrapper.url "$srcdir/yalibvlcwrapper"
+ git submodule update
+
+ cd "libvlc_wrapper"
+ git submodule init
+ git config submodule.libvlc-sdk.url "$srcdir/libvlcsdk"
+ git submodule update
+
+ popd >> /dev/null
+
+ mkdir -p build
+ cd build
+ qmake "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd build
+ make INSTALL_ROOT="$pkgdir" install
+
+ mkdir -p "$pkgdir"/usr/bin
+ mkdir -p "$pkgdir"/usr/share/applications
+
+ # for i in 16x16 22x22 32x32 48x48 64x64 128x128 256x256; do
+ # install -Dm644 "$srcdir"/"$pkgname"/icons/liri-player.png \
+ # "$pkgdir"/usr/share/icons/hicolor/$i/apps/liri-player.png
+ # done
+
+ # install -m755 ../liri-player.sh \
+ # "$pkgdir"/usr/bin/liri-player
+
+ install -m755 liri-player \
+ "$pkgdir"/usr/bin/liri-player
+ install -m755 ../liri-player.desktop \
+ "$pkgdir"/usr/share/applications/liri-player.desktop
+}
+
+# Additional functions to generate a changelog
+
+changelog() {
+ cd "$pkgname"
+ git log $1..HEAD --no-merges --format=" * %s"
+}
+
+gitref() {
+ cd "$pkgname"
+ git rev-parse HEAD
+}
diff --git a/liri-player-git.install b/liri-player-git.install
new file mode 100644
index 000000000000..cd3b519abf28
--- /dev/null
+++ b/liri-player-git.install
@@ -0,0 +1,35 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+_update() {
+ msg_blue "Updating desktop MIME database..."
+ update-desktop-database -q
+
+ msg_blue "Updating icon cache.."
+ xdg-icon-resource forceupdate --theme hicolor &>/dev/null
+}
+
+post_install() {
+ _update
+ note "Custom flags should be put directly in: ~/.config/liri-flags.conf"
+ note "The launcher is called: 'liri-browser'"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ _update
+}
diff --git a/liri-player.desktop b/liri-player.desktop
new file mode 100644
index 000000000000..510e14aa852c
--- /dev/null
+++ b/liri-player.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Liri Player
+Comment=Play media files
+Keywords=media;video;movie;videos;movies;
+GenericName=Media Player
+Exec=liri-player
+Icon=liri-player
+Terminal=false
+StartupNotify=true
+Type=Application
+Categories=Video;Media;QT;QML;