summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPier Luigi Fiorini2018-08-25 08:25:42 +0200
committerPier Luigi Fiorini2018-08-25 08:25:42 +0200
commitab24b6184b311f2e02f21f6df59d97b62d9ef53d (patch)
treebc9dc0e00b55a09ab5f845f99a70bc58ea7799c2
downloadaur-ab24b6184b311f2e02f21f6df59d97b62d9ef53d.tar.gz
Initial import
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD43
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd3be03d0da1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Sat Aug 25 06:24:29 UTC 2018
+pkgbase = liri-power-manager-git
+ pkgdesc = Manages the power consumption settings of Liri Shell
+ pkgver = 20180825.60.970e91e
+ pkgrel = 1
+ url = https://liri.io
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ groups = liri-git
+ license = GPL3
+ makedepends = git
+ makedepends = liri-qbs-shared-git
+ depends = qt5-tools
+ depends = fluid-git
+ depends = libliri-git
+ provides = liri-power-manager
+ conflicts = liri-power-manager
+ replaces = liri-power-manager
+ options = debug
+ options = !strip
+ source = power-manager::git://github.com/lirios/power-manager.git#branch=develop
+ md5sums = SKIP
+
+pkgname = liri-power-manager-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c456d3f3553
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
+
+pkgname=liri-power-manager-git
+pkgver=20180825.60.970e91e
+pkgrel=1
+pkgdesc="Manages the power consumption settings of Liri Shell"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url='https://liri.io'
+license=('GPL3')
+depends=('qt5-tools' 'fluid-git' 'libliri-git')
+makedepends=('git' 'liri-qbs-shared-git')
+options=(debug !strip)
+conflicts=('liri-power-manager')
+replaces=('liri-power-manager')
+provides=('liri-power-manager')
+groups=('liri-git')
+
+_gitroot="git://github.com/lirios/power-manager.git"
+_gitbranch=develop
+_gitname=power-manager
+source=(${_gitname}::${_gitroot}#branch=${_gitbranch})
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${_gitname}
+ echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git rev-list --count HEAD).$(git log -1 --format="%h")"
+}
+
+build() {
+ cd ${srcdir}/${_gitname}
+ qbs setup-toolchains --type gcc /usr/bin/g++ gcc
+ qbs setup-qt /usr/bin/qmake-qt5 qt5
+ qbs config profiles.qt5.baseProfile gcc
+ qbs build --no-install -d build config:debug qbs.buildVariant:debug profile:qt5 \
+ modules.lirideployment.prefix:/usr \
+ modules.lirideployment.qmlDir:/usr/lib/qt/qml \
+ modules.lirideployment.pluginsDir:/usr/lib/qt/plugins
+}
+
+package() {
+ cd ${srcdir}/${_gitname}
+ qbs install -d build --no-build -v --install-root $pkgdir config:debug profile:qt5
+}