summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPier Luigi Fiorini2017-01-23 22:02:39 +0100
committerPier Luigi Fiorini2017-01-23 22:02:39 +0100
commit11f4c8f6220c3d25a0f900722b173a176d93f3d8 (patch)
tree7864979364f4d575fc1b5116cf97410b45a93744
downloadaur-11f4c8f6220c3d25a0f900722b173a176d93f3d8.tar.gz
Initial import
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD39
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0afba436c441
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+# Generated by mksrcinfo v8
+# Mon Jan 23 21:02:30 UTC 2017
+pkgbase = liri-shell
+ pkgdesc = QtQuick and Wayland based shell for convergence
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://liri.io
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ groups = liri
+ license = GPL3
+ makedepends = extra-cmake-modules
+ depends = qt5-tools
+ depends = qt5-wayland
+ depends = qt5-accountsservice
+ depends = pam
+ depends = greenisland-git
+ depends = vibe
+ depends = liri-workspace
+ optdepends = weston: nested mode support
+ conflicts = hawaii-shell
+ conflicts = papyros-shell
+ conflicts = liri-shell-git
+ replaces = hawaii-shell
+ replaces = papyros-shell
+ source = https://github.com/lirios/shell/releases/download/v0.9.0/liri-shell-0.9.0.tar.xz
+ sha256sums = 09ad65078beedca1119297f15c4dc7d392fb9cbdf92338aea457dfffd636f339
+
+pkgname = liri-shell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60e0f8dbec83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
+
+_modulename=shell
+
+pkgname=liri-${_modulename}
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="QtQuick and Wayland based shell for convergence"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url='https://liri.io'
+license=('GPL3')
+depends=('qt5-tools' 'qt5-wayland' 'qt5-accountsservice'
+ 'pam' 'greenisland-git' 'vibe' 'liri-workspace')
+optdepends=('weston: nested mode support')
+makedepends=('extra-cmake-modules')
+conflicts=('hawaii-shell' 'papyros-shell' 'liri-shell-git')
+replaces=('hawaii-shell' 'papyros-shell')
+groups=('liri')
+source=("https://github.com/lirios/${_modulename}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('09ad65078beedca1119297f15c4dc7d392fb9cbdf92338aea457dfffd636f339')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../${pkgname}-${pkgver} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DKDE_INSTALL_LIBDIR=lib \
+ -DKDE_INSTALL_LIBEXECDIR=lib
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}