summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPier Luigi Fiorini2016-10-13 21:37:54 +0200
committerPier Luigi Fiorini2016-10-13 21:38:08 +0200
commit08f1ce9c7eaf2027f9a716d3d1948c8ee7b42dea (patch)
tree53e805d87b480f0e01b6c98e2267d72de5c092c8
downloadaur-08f1ce9c7eaf2027f9a716d3d1948c8ee7b42dea.tar.gz
Initial import
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD47
2 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8463f6948e09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+# Generated by mksrcinfo v8
+# Tue Oct 11 20:50:41 UTC 2016
+pkgbase = liri-shell-git
+ pkgdesc = QtQuick and Wayland based shell for convergence
+ pkgver = 20161004.f59b340
+ pkgrel = 1
+ url = http://liri.io
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ groups = liri-git
+ license = GPL3
+ makedepends = git
+ makedepends = extra-cmake-modules
+ depends = qt5-tools
+ depends = qt5-graphicaleffects
+ depends = qt5-wayland
+ depends = qt5-accountsservice-git
+ depends = pam
+ depends = libqtxdg
+ depends = greenisland-git
+ depends = vibe-git
+ depends = liri-workspace-git
+ optdepends = weston: nested mode support
+ provides = liri-shell
+ conflicts = hawaii-shell-git
+ conflicts = papyros-shell-git
+ conflicts = liri-shell
+ replaces = hawaii-shell-git
+ replaces = papyros-shell-git
+ replaces = liri-shell
+ source = shell::git://github.com/lirios/shell.git#branch=develop
+ md5sums = SKIP
+
+pkgname = liri-shell-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee8b31c30e21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
+
+pkgname=liri-shell-git
+pkgver=20161004.f59b340
+pkgrel=1
+pkgdesc="QtQuick and Wayland based shell for convergence"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url='http://liri.io'
+license=('GPL3')
+depends=('qt5-tools' 'qt5-graphicaleffects' 'qt5-wayland' 'qt5-accountsservice-git'
+ 'pam' 'libqtxdg' 'greenisland-git' 'vibe-git' 'liri-workspace-git')
+optdepends=('weston: nested mode support')
+makedepends=('git' 'extra-cmake-modules')
+conflicts=('hawaii-shell-git' 'papyros-shell-git' 'liri-shell')
+replaces=('hawaii-shell-git' 'papyros-shell-git' 'liri-shell')
+provides=('liri-shell')
+groups=('liri-git')
+
+_gitroot="git://github.com/lirios/shell.git"
+_gitbranch=develop
+_gitname=shell
+source=(${_gitname}::${_gitroot}#branch=${_gitbranch})
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${_gitname}
+ echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git log -1 --format="%h")"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../${_gitname} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DKDE_INSTALL_LIBDIR=lib \
+ -DKDE_INSTALL_LIBEXECDIR=lib
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}