summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPier Luigi Fiorini2017-01-01 16:50:23 +0100
committerPier Luigi Fiorini2017-01-01 16:50:23 +0100
commitb244cc63de6b65eda61313abfb17da76e4c8f5e0 (patch)
tree6371d4dfede5b82effe7cac1443e9d1bef2e011a
downloadaur-b244cc63de6b65eda61313abfb17da76e4c8f5e0.tar.gz
Initial version
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e246b23d076
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Jan 1 15:50:17 UTC 2017
+pkgbase = liri-themes
+ pkgdesc = Themes for uniform look and feel throughout Liri OS
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://liri.io
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ groups = liri
+ license = GPL3
+ makedepends = extra-cmake-modules
+ conflicts = liri-themes-git
+ source = https://github.com/lirios/liri-themes/releases/download/v0.9.0/liri-themes-0.9.0.tar.xz
+ sha256sums = 59ebc01231ebf955fd847db925fca1c557273da126087af2dfe09013321a54b5
+
+pkgname = liri-themes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45e091535a59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
+
+pkgname=liri-themes
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="Themes for uniform look and feel throughout Liri OS"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url='https://liri.io'
+license=('GPL3')
+makedepends=('extra-cmake-modules')
+conflicts=('liri-themes-git')
+groups=('liri')
+source=("https://github.com/lirios/${pkgname}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('59ebc01231ebf955fd847db925fca1c557273da126087af2dfe09013321a54b5')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../${pkgname}-${pkgver} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DKDE_INSTALL_LIBDIR=lib \
+ -DKDE_INSTALL_LIBEXECDIR=lib
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}