summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPier Luigi Fiorini2017-01-29 23:42:33 +0100
committerPier Luigi Fiorini2017-01-29 23:42:33 +0100
commit5932aebe0dde86434d872b7cca8560e9904ffecd (patch)
tree8b9bf6adaaa11a434e4a786e202bfd815c4821a9
downloadaur-5932aebe0dde86434d872b7cca8560e9904ffecd.tar.gz
Initial import
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD46
2 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ee4e7012637
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+# Generated by mksrcinfo v8
+# Sun Jan 29 22:42:30 UTC 2017
+pkgbase = liri-wayland-git
+ pkgdesc = QtWayland additions and QPA plugin
+ pkgver = 20170127.86184df
+ pkgrel = 1
+ url = https://liri.io
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ groups = liri-git
+ license = GPL3
+ makedepends = git
+ makedepends = extra-cmake-modules
+ makedepends = xcb-util-cursor
+ makedepends = libxcursor
+ depends = systemd
+ depends = wayland-protocols
+ depends = libdrm
+ depends = libinput
+ depends = qt5-declarative
+ depends = qt5-wayland
+ depends = xkeyboard-config
+ depends = libxkbcommon
+ depends = glib2
+ depends = fontconfig
+ depends = freetype2
+ provides = liri-wayland
+ conflicts = liri-wayland
+ replaces = liri-wayland
+ source = wayland::git://github.com/lirios/wayland.git#branch=develop
+ md5sums = SKIP
+
+pkgname = liri-wayland-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77505c771e82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
+
+pkgname=liri-wayland-git
+pkgver=20170127.86184df
+pkgrel=1
+pkgdesc="QtWayland additions and QPA plugin"
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url='https://liri.io'
+license=('GPL3')
+depends=('systemd' 'wayland-protocols' 'libdrm' 'libinput' 'qt5-declarative' 'qt5-wayland'
+ 'xkeyboard-config' 'libxkbcommon' 'glib2' 'fontconfig' 'freetype2')
+makedepends=('git' 'extra-cmake-modules' 'xcb-util-cursor' 'libxcursor')
+provides=('liri-wayland')
+conflicts=('liri-wayland')
+replaces=('liri-wayland')
+groups=('liri-git')
+
+_gitroot="git://github.com/lirios/wayland.git"
+_gitbranch=develop
+_gitname=wayland
+source=(${_gitname}::${_gitroot}#branch=${_gitbranch})
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${_gitname}
+ echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git log -1 --format="%h")"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../${_gitname} \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DKDE_INSTALL_LIBDIR=lib \
+ -DKDE_INSTALL_LIBEXECDIR=lib
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}