summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPier Luigi Fiorini2017-05-14 20:41:44 +0200
committerPier Luigi Fiorini2017-05-14 20:41:44 +0200
commite77d8641a6e08a87e17bbb8a3f9b36b1b391a8ba (patch)
tree7253ce41140ab5bcd50e381fbf44b14e41c107ef
parent710a934c77a2a1d1bb8483879bc5327b1917aced (diff)
downloadaur-e77d8641a6e08a87e17bbb8a3f9b36b1b391a8ba.tar.gz
Build with qbs
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c569c16d57a9..9f0cfb2b1f79 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Jan 30 08:09:25 UTC 2017
+# Sun May 14 18:41:40 UTC 2017
pkgbase = liri-wayland-git
pkgdesc = QtWayland additions and QPA plugin
- pkgver = 20170130.cf49d8d
+ pkgver = 20170514.732a453
pkgrel = 1
url = https://liri.io
arch = i686
@@ -12,7 +12,7 @@ pkgbase = liri-wayland-git
groups = liri-git
license = GPL3
makedepends = git
- makedepends = extra-cmake-modules
+ makedepends = qbs
makedepends = xcb-util-cursor
makedepends = libxcursor
depends = systemd
diff --git a/PKGBUILD b/PKGBUILD
index 6860723389a2..737dcf35c4e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Pier Luigi Fiorini <pierluigi.fiorini@gmail.com>
pkgname=liri-wayland-git
-pkgver=20170130.cf49d8d
+pkgver=20170514.732a453
pkgrel=1
pkgdesc="QtWayland additions and QPA plugin"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -9,7 +9,7 @@ url='https://liri.io'
license=('GPL3')
depends=('systemd' 'wayland-protocols' 'libdrm' 'libinput' 'qt5-declarative' 'qt5-wayland'
'xkeyboard-config' 'libxkbcommon' 'glib2' 'fontconfig' 'freetype2')
-makedepends=('git' 'extra-cmake-modules' 'xcb-util-cursor' 'libxcursor')
+makedepends=('git' 'qbs' 'xcb-util-cursor' 'libxcursor')
conflicts=('greenisland' 'greenisland-git' 'liri-wayland')
replaces=('greenisland' 'greenisland-git' 'liri-wayland')
provides=('liri-wayland')
@@ -27,21 +27,19 @@ pkgver() {
}
prepare() {
- mkdir -p build
+ cd ${srcdir}/${_gitname}
+ git submodule update --init
}
build() {
- cd build
- cmake ../${_gitname} \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DKDE_INSTALL_LIBDIR=lib \
- -DKDE_INSTALL_LIBEXECDIR=lib \
- -DBUILD_HACK=ON
- make
+ cd ${srcdir}/${_gitname}
+ qbs setup-toolchains --type gcc /usr/bin/g++ gcc
+ qbs setup-qt /usr/bin/qmake-qt5 qt5
+ qbs config profiles.qt5.baseProfile gcc
+ qbs build --no-install -d build profile:qt5 qbs.installRoot:/usr lirideployment.qmlDir:lib/qt/qml lirideployment.pluginsDir:lib/qt/plugins
}
package() {
- cd build
- make DESTDIR="${pkgdir}" install
+ cd ${srcdir}/${_gitname}
+ qbs install -d build --no-build -v --install-root $pkgdir/usr profile:qt5
}