summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArenM2022-07-05 23:22:53 -0400
committerArenM2022-07-05 23:35:27 -0400
commit402be2cea8c5de9d2a60a23315b9324934e9825b (patch)
tree9885f2eb4205bbe78d645a44dedfc04338ebe97b
parent636aab2e21ddf010b2a76090e5c910297b215fb5 (diff)
downloadaur-402be2cea8c5de9d2a60a23315b9324934e9825b.tar.gz
Update to 0.3.4
This includes some refactoring to make this PKGBUILD more like the one used for the danctnix package, which is available at: https://github.com/dreemurrs-embedded/Pine64-Arch/blob/9e32d81342772db37ddfa30eaff9162c0e10a814/PKGBUILDS/sxmo/lisgd/PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--Makefile.patch4
-rw-r--r--PKGBUILD38
3 files changed, 23 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33e6c9eef71f..dde57b82379a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
pkgbase = lisgd
pkgdesc = Bind gestures on touchscreens, and unsupported gesture devices via libinput touch events
- pkgver = 0.1.1
+ pkgver = 0.3.4
pkgrel = 1
url = https://git.sr.ht/~mil/lisgd
- arch = any
+ arch = x86_64
+ arch = i686
+ arch = armv7h
+ arch = aarch64
license = MIT
depends = libinput
- source = lisgd-0.1.1.tar.gz::https://git.sr.ht/~mil/lisgd/archive/0.1.1.tar.gz
- source = Makefile.patch
- sha1sums = cae9863918604ffd4c01f2ce30425eecd45c56c9
- sha1sums = 601e3fa3cf64bc9b5b2509ee60099b95c79979d0
+ depends = libx11
+ depends = wayland
+ source = lisgd-0.3.4.tar.gz::https://git.sr.ht/~mil/lisgd/archive/0.3.4.tar.gz
+ sha512sums = 53378491c0ba9f124ca0772c81099f4639387666b94bf16305dc560fc22d83e7155e9dde3817978616d2e241f4831eae3dab7d4fd5ef3020d9c5ecf4520b9ecd
pkgname = lisgd
-
diff --git a/Makefile.patch b/Makefile.patch
deleted file mode 100644
index 55047e15e19f..000000000000
--- a/Makefile.patch
+++ /dev/null
@@ -1,4 +0,0 @@
-31c31
-< chmod 644 ${DESTDIR}${PREFIX}/share/man/man1
----
-> chmod 755 ${DESTDIR}${PREFIX}/share/man/man1
diff --git a/PKGBUILD b/PKGBUILD
index c729a1096a27..09aea57c8401 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,24 @@
-# Maintainer: Fronkles McFranko <mrelfranko@disroot.org>
+# Maintainer: Aren <rn+aur@peacevolution.org>
+# Contributor: dni <office@dnilabs.com>
+# Contributor: Fronkles McFranko <mrelfranko@disroot.org>
+
pkgname=lisgd
-pkgver=0.1.1
+pkgver=0.3.4
pkgrel=1
-epoch=
pkgdesc="Bind gestures on touchscreens, and unsupported gesture devices via libinput touch events"
-arch=("any")
url="https://git.sr.ht/~mil/lisgd"
+arch=('x86_64' 'i686' 'armv7h' 'aarch64')
license=('MIT')
-groups=()
-depends=(libinput)
-makedepends=()
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
-source=("$pkgname-$pkgver.tar.gz::https://git.sr.ht/~mil/${pkgname}/archive/${pkgver}.tar.gz"
- "Makefile.patch")
-sha1sums=("cae9863918604ffd4c01f2ce30425eecd45c56c9"
- "601e3fa3cf64bc9b5b2509ee60099b95c79979d0")
+depends=('libinput' 'libx11' 'wayland')
+source=("$pkgname-$pkgver.tar.gz::https://git.sr.ht/~mil/lisgd/archive/$pkgver.tar.gz")
+sha512sums=('53378491c0ba9f124ca0772c81099f4639387666b94bf16305dc560fc22d83e7155e9dde3817978616d2e241f4831eae3dab7d4fd5ef3020d9c5ecf4520b9ecd')
-prepare() {
- patch "$pkgname-$pkgver/Makefile" -i Makefile.patch
+build() {
+ cd "$pkgname-$pkgver"
+ make
}
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" PREFIX="/usr/" install
+ cd "$pkgname-$pkgver"
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
}