summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-02-01 13:44:48 +0100
committerAlexander F. Rødseth2019-02-01 13:44:48 +0100
commit22bf2a55f5f33983b6d83290b950ceff73e4f9ca (patch)
treeba250391b7c4e7ef6ed11ecb2fb585af9c0abe1e
downloadaur-22bf2a55f5f33983b6d83290b950ceff73e4f9ca.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e10686128d1a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Fri Feb 1 12:44:39 UTC 2019
+pkgbase = lisp
+ pkgdesc = Wrapper scripts for SBCL, for programming in Common Lisp
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/xyproto/lisp
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = sbcl
+ source = git+https://github.com/xyproto/lisp#tag=1.2.0
+ sha256sums = SKIP
+
+pkgname = lisp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9210be07f81c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=lisp
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='Wrapper scripts for SBCL, for programming in Common Lisp'
+arch=(any)
+url='https://github.com/xyproto/lisp'
+license=(GPL2)
+depends=(sbcl)
+makedepends=(git)
+source=("git+$url#tag=$pkgver")
+sha256sums=(SKIP)
+
+check() {
+ getent passwd "$USER" | cut -d: -f5 | make -C $pkgname test
+}
+
+package() {
+ DESTDIR="$pkgdir" make -C "$pkgname" install
+}
+
+# vim: ts=2 sw=2 et:
+