summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2016-10-03 12:28:44 -0400
committerDavid Parrish2016-10-03 12:28:44 -0400
commit3281bad454952dc5b96234d48202047051f04699 (patch)
treeef7ff0b2ea3c0eafb4203e60cd242012cda7e9b6
downloadaur-3281bad454952dc5b96234d48202047051f04699.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71b4eecaeb7c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Oct 3 16:28:33 UTC 2016
+pkgbase = list-all-systemd-timers-git
+ pkgdesc = Prints all systemd timers to stdout
+ pkgver = r5.175bcac
+ pkgrel = 1
+ url = https://github.com/dmp1ce/list-all-systemd-timers
+ arch = i686
+ arch = x86_64
+ license = custom:Unlicense
+ makedepends = git
+ makedepends = ghc
+ options = strip
+ source = list-all-systemd-timers-git::git+https://github.com/dmp1ce/list-all-systemd-timers.git
+ sha256sums = SKIP
+
+pkgname = list-all-systemd-timers-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9402049b40a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: David Parrish <daveparrish@tutanota.com>
+
+pkgname=list-all-systemd-timers-git
+pkgver=r5.175bcac
+pkgrel=1
+pkgdesc="Prints all systemd timers to stdout"
+arch=('i686' 'x86_64')
+makedepends=('git' 'ghc')
+url="https://github.com/dmp1ce/list-all-systemd-timers"
+license=('custom:Unlicense')
+options=('strip')
+source=("${pkgname}::git+https://github.com/dmp1ce/list-all-systemd-timers.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ msg2 'Building...'
+ cd "${pkgname}"
+ ghc --make list-all-systemd-timers.hs
+}
+
+package() {
+ cd "${pkgname}"
+
+ msg2 'Installing license...'
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/list-all-systemd-timers"
+
+ msg2 'Installing...'
+ mkdir -p "$pkgdir/usr/bin"
+ install -Dm 755 list-all-systemd-timers -t "$pkgdir/usr/bin"
+}