summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-07-14 11:32:30 +0800
committerzxp198210052023-07-14 11:32:30 +0800
commit0ad3806a447a5e39371dce1fa992ed899db3c8e5 (patch)
treeeaef32a25dfe84c763910b7272fea466dc4b6dc5
downloadaur-0ad3806a447a5e39371dce1fa992ed899db3c8e5.tar.gz
first release
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
-rw-r--r--listen1-desktop.sh6
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6091ccc77c84
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = listen1-desktop-bin
+ pkgdesc = One for all free music in China
+ pkgver = 2.29.0
+ pkgrel = 1
+ url = http://listen1.github.io/listen1
+ arch = x86_64
+ license = MIT
+ makedepends = asar
+ makedepends = gendesk
+ depends = electron13
+ provides = listen1-desktop
+ conflicts = listen1-desktop
+ conflicts = listen1
+ source = listen1-desktop-2.29.0.tar.gz::https://github.com/listen1/listen1_desktop/releases/download/v2.29.0/listen1_2.29.0_linux_x64.tar.gz
+ source = LICENSE.md::https://raw.githubusercontent.com/listen1/listen1_desktop/master/LICENSE.md
+ source = listen1-desktop.sh
+ sha256sums = 2144bd12b99916355badd27970d22a084153a45b536766746f32c6b1941013b3
+ sha256sums = d2aa8a82485042b9d5efb8ed2d9c0e8a66e8983bc3f64ebbe35158d35662cdbc
+ sha256sums = bd9b80208045429b063c0b45e5485ab467bfe788e93bbd875ebbc815c3c71167
+
+pkgname = listen1-desktop-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5bfda8acecb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=listen1-desktop-bin
+pkgver="2.29.0"
+pkgrel=1
+pkgdesc="One for all free music in China"
+arch=("x86_64")
+url="http://listen1.github.io/listen1"
+_githuburl="https://github.com/listen1/listen1_desktop"
+license=('MIT')
+depends=('electron13')
+makedepends=('asar' 'gendesk')
+conflicts=("${pkgname%-bin}" "${pkgname%-desktop-bin}")
+provides=("${pkgname%-bin}")
+source=("${pkgname%-bin}-${pkgver}.tar.gz::${_githuburl}/releases/download/v${pkgver}/${pkgname%-desktop-bin}_${pkgver}_linux_x64.tar.gz"
+ "LICENSE.md::https://raw.githubusercontent.com/listen1/listen1_desktop/master/LICENSE.md"
+ "${pkgname%-bin}.sh")
+sha256sums=('2144bd12b99916355badd27970d22a084153a45b536766746f32c6b1941013b3'
+ 'd2aa8a82485042b9d5efb8ed2d9c0e8a66e8983bc3f64ebbe35158d35662cdbc'
+ 'bd9b80208045429b063c0b45e5485ab467bfe788e93bbd875ebbc815c3c71167')
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${pkgname%-desktop-bin}_${pkgver}_linux_x64/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
+ asar extract "${srcdir}/${pkgname%-desktop-bin}_${pkgver}_linux_x64/resources/app.asar" "${srcdir}/app.asar.unpacked"
+ install -Dm644 "${srcdir}/app.asar.unpacked/resources/logo512.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
+ gendesk -f -n --icon "${pkgname%-bin}" --categories "AudioVideo" --name "Listen1" --exec "/opt/${pkgname%-bin}/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -Dm644 "${srcdir}/LICENSE.md" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+} \ No newline at end of file
diff --git a/listen1-desktop.sh b/listen1-desktop.sh
new file mode 100644
index 000000000000..7e12f8461089
--- /dev/null
+++ b/listen1-desktop.sh
@@ -0,0 +1,6 @@
+#!/bin/bash
+if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
+ exec electron13 /opt/listen1-desktop/listen1-desktop.asar "$@"
+else
+ exec electron13 --no-sandbox /opt/listen1-desktop/listen1-desktop.asar "$@"
+fi \ No newline at end of file