summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-02-05 13:33:42 +0800
committerzxp198210052024-02-05 13:33:42 +0800
commit7336e960a8cc01d3f13e7d5bd84571b7a80497b5 (patch)
tree24f5e760b0d1e1791e0b56420f0f0d5b36ceb70c
parent85fe19836c6d605b43058d9060353603b7a4c0eb (diff)
downloadaur-7336e960a8cc01d3f13e7d5bd84571b7a80497b5.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--listen1-desktop.sh11
3 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 548d08b1851a..52e9fb619b43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = listen1-desktop-bin
pkgdesc = One for all free music in China
pkgver = 2.31.0
- pkgrel = 5
+ pkgrel = 6
url = http://listen1.github.io/listen1
arch = x86_64
license = MIT
@@ -16,6 +16,6 @@ pkgbase = listen1-desktop-bin
source = listen1-desktop.sh
sha256sums = 0623e152524477d1015b2619bb1784d82473de6153b8b78a892783fb9e0894f9
sha256sums = d2aa8a82485042b9d5efb8ed2d9c0e8a66e8983bc3f64ebbe35158d35662cdbc
- sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
+ sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
pkgname = listen1-desktop-bin
diff --git a/PKGBUILD b/PKGBUILD
index 872312e70aec..b606510c9dad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgname="${_pkgname}-desktop-bin"
_appname=Listen1
_electronversion=13
pkgver=2.31.0
-pkgrel=5
+pkgrel=6
pkgdesc="One for all free music in China"
arch=("x86_64")
url="http://listen1.github.io/listen1"
@@ -27,11 +27,11 @@ source=(
)
sha256sums=('0623e152524477d1015b2619bb1784d82473de6153b8b78a892783fb9e0894f9'
'd2aa8a82485042b9d5efb8ed2d9c0e8a66e8983bc3f64ebbe35158d35662cdbc'
- '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
+ '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
- -e "s|@appasar@|app.asar|g" \
+ -e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
sed "s|/opt/${_appname}/${_pkgname}|${pkgname%-bin}|g;s|Icon=${_pkgname}|Icon=${pkgname%-bin}|g;s|Audio|AudioVideo|g" \
diff --git a/listen1-desktop.sh b/listen1-desktop.sh
index c77c53567639..f9ced1432cfc 100644
--- a/listen1-desktop.sh
+++ b/listen1-desktop.sh
@@ -1,17 +1,14 @@
#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
-_ASAR="${_APPDIR}/@appasar@"
+_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" "$@"
- exit
+ exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
else
- cd "${_APPDIR}"
- exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
- exit
+ exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file