summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-14 16:07:55 +0800
committerzxp198210052023-09-14 16:07:55 +0800
commit95547f392c8fcebd8031afb9f8d6f4bdbdc02006 (patch)
treed2e0802d3fd459ffc233a35107ba10fb332751a5
parent0c9f38062e98cd2af284753834670b5a85a4fd41 (diff)
downloadaur-95547f392c8fcebd8031afb9f8d6f4bdbdc02006.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--listen1-desktop.sh2
3 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa9608e548f7..14100f5caeb2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = listen1-desktop-bin
pkgdesc = One for all free music in China
pkgver = 2.31.0
- pkgrel = 2
+ pkgrel = 3
url = http://listen1.github.io/listen1
arch = x86_64
license = MIT
@@ -13,10 +13,10 @@ pkgbase = listen1-desktop-bin
conflicts = listen1-desktop
conflicts = listen1
source = listen1-desktop-2.31.0.tar.gz::https://github.com/listen1/listen1_desktop/releases/download/v2.31.0/listen1_2.31.0_linux_x64.tar.gz
- source = LICENSE.md::https://raw.githubusercontent.com/listen1/listen1_desktop/master/LICENSE.md
+ source = LICENSE.md::https://raw.githubusercontent.com/listen1/listen1_desktop/v2.31.0/LICENSE.md
source = listen1-desktop.sh
sha256sums = 9ce7d408812b7532d8bff8f2f41c1d226cecb618cbca7e5a37d2d5c780f337c2
sha256sums = d2aa8a82485042b9d5efb8ed2d9c0e8a66e8983bc3f64ebbe35158d35662cdbc
- sha256sums = 69cd307012d2f4bf64a4f7792b0df4af38666a7ef66046d1ef791e6b46c01e6f
+ sha256sums = 5d1b5c05a863bf337e69e874e4f18fb42330b1d42aaece12ac2fd87705b59914
pkgname = listen1-desktop-bin
diff --git a/PKGBUILD b/PKGBUILD
index 08de95321cad..3811c44786a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=listen1-desktop-bin
pkgver=2.31.0
-pkgrel=2
+pkgrel=3
pkgdesc="One for all free music in China"
arch=("x86_64")
url="http://listen1.github.io/listen1"
@@ -12,17 +12,19 @@ conflicts=("${pkgname%-bin}" "${pkgname%-desktop-bin}")
depends=('bash' 'electron13')
makedepends=('asar' 'gendesk')
source=("${pkgname%-bin}-${pkgver}.tar.gz::${_githuburl}/releases/download/v${pkgver}/${pkgname%-desktop-bin}_${pkgver}_linux_x64.tar.gz"
- "LICENSE.md::https://raw.githubusercontent.com/listen1/listen1_desktop/master/LICENSE.md"
+ "LICENSE.md::https://raw.githubusercontent.com/listen1/listen1_desktop/v${pkgver}/LICENSE.md"
"${pkgname%-bin}.sh")
sha256sums=('9ce7d408812b7532d8bff8f2f41c1d226cecb618cbca7e5a37d2d5c780f337c2'
'd2aa8a82485042b9d5efb8ed2d9c0e8a66e8983bc3f64ebbe35158d35662cdbc'
- '69cd307012d2f4bf64a4f7792b0df4af38666a7ef66046d1ef791e6b46c01e6f')
-package() {
- install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}"
- install -Dm644 "${srcdir}/${pkgname%-desktop-bin}_${pkgver}_linux_x64/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.asar"
+ '5d1b5c05a863bf337e69e874e4f18fb42330b1d42aaece12ac2fd87705b59914')
+prepare() {
asar extract "${srcdir}/${pkgname%-desktop-bin}_${pkgver}_linux_x64/resources/app.asar" "${srcdir}/app.asar.unpacked"
+ gendesk -f -n --categories "AudioVideo" --name "Listen1" --exec "${pkgname%-bin}"
+}
+package() {
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm644 "${srcdir}/${pkgname%-desktop-bin}_${pkgver}_linux_x64/resources/app.asar" "${pkgdir}/opt/${pkgname%-bin}/resources/${pkgname%-bin}.asar"
install -Dm644 "${srcdir}/app.asar.unpacked/resources/logo512.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
- gendesk -f -n --icon "${pkgname%-bin}" --categories "AudioVideo" --name "Listen1" --exec "/opt/${pkgname%-bin}/${pkgname%-bin}"
install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
install -Dm644 "${srcdir}/LICENSE.md" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file
diff --git a/listen1-desktop.sh b/listen1-desktop.sh
index e4b9689e4152..2e67a7191531 100644
--- a/listen1-desktop.sh
+++ b/listen1-desktop.sh
@@ -1,6 +1,6 @@
#!/bin/bash
_ELECTRON=/usr/bin/electron13
-_ASAR="/opt/listen1-desktop/listen1-desktop.asar"
+_ASAR="/opt/listen1-desktop/resources/listen1-desktop.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"
else