summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-05-17 10:45:14 +0300
committerCaleb Maclennan2021-05-17 10:45:14 +0300
commit46320e4cbab528af1a389d7724a84cc085fb96fb (patch)
treef837667a87c65c61d0594e286adeb87bf0506159
parent1401ef9e0cc2125b25af8624903c74d5001de733 (diff)
downloadaur-46320e4cbab528af1a389d7724a84cc085fb96fb.tar.gz
upgpkg: listmonk-bin 1.0.0-1
upstream release
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
-rw-r--r--listmonk.toml22
3 files changed, 15 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdc4b77397ee..5419481fa1c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = listmonk-bin
pkgdesc = Self-hosted newsletter and mailing list manager with a modern dashboard
- pkgver = 0.9.0
- pkgrel = 7
+ pkgver = 1.0.0
+ pkgrel = 1
url = https://listmonk.app
install = listmonk.install
arch = x86_64
@@ -11,14 +11,14 @@ pkgbase = listmonk-bin
conflicts = listmonk
options = !strip
backup = etc/listmonk/config.toml
- source = https://github.com/knadh/listmonk/releases/download/v0.9.0-beta/listmonk_0.9.0-beta_linux_amd64.tar.gz
+ source = https://github.com/knadh/listmonk/releases/download/v1.0.0/listmonk_1.0.0_linux_amd64.tar.gz
+ source = listmonk-1.0.0.toml::https://raw.githubusercontent.com/knadh/listmonk/v1.0.0/config.toml.sample
source = listmonk.conf
source = listmonk.service
- source = listmonk.toml
- sha256sums = 1137f572fd93b25034865cb638d169acb1bd9b87d6848c274405bc6108dad62c
+ sha256sums = 7e8ff7d5e351155142382820b5014451da208c4cc7a5dde9d163cd999287057f
+ sha256sums = b0fbe305ff7c55328cdc2f0b96bb18e7ea393276a1821bc5fba43f9072474f38
sha256sums = 5cfc186438df2408ed88a5bec3a9a4b5f2afb0d3aec41c4cc63b2f5eb810b3cb
sha256sums = 809ede70c932183889b2fa567b340fb82cce1ada76c7b0a0b9efb82b87c92fa0
- sha256sums = d341df55eb474ea323d22653af8698af70fca08713490cb917ed6ecacb63c41a
pkgname = listmonk-bin
diff --git a/PKGBUILD b/PKGBUILD
index 006cdf265bcf..e11274fe2fe3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=listmonk-bin
_pkgname=${pkgname%-bin}
-pkgver=0.9.0
-pkgrel=7
+pkgver=1.0.0
+pkgrel=1
pkgdesc='Self-hosted newsletter and mailing list manager with a modern dashboard'
arch=(x86_64)
url=https://listmonk.app
@@ -14,18 +14,18 @@ conflicts=("$_pkgname")
backup=(etc/listmonk/config.toml)
options=('!strip')
install=$_pkgname.install
-source=("https://github.com/knadh/$_pkgname/releases/download/v$pkgver-beta/${_pkgname}_$pkgver-beta_linux_amd64.tar.gz"
+source=("https://github.com/knadh/$_pkgname/releases/download/v$pkgver/${_pkgname}_${pkgver}_linux_amd64.tar.gz"
+ "$_pkgname-$pkgver.toml::https://raw.githubusercontent.com/knadh/$_pkgname/v$pkgver/config.toml.sample"
"$_pkgname.conf"
- "$_pkgname.service"
- "$_pkgname.toml")
-sha256sums=('1137f572fd93b25034865cb638d169acb1bd9b87d6848c274405bc6108dad62c'
+ "$_pkgname.service")
+sha256sums=('7e8ff7d5e351155142382820b5014451da208c4cc7a5dde9d163cd999287057f'
+ 'b0fbe305ff7c55328cdc2f0b96bb18e7ea393276a1821bc5fba43f9072474f38'
'5cfc186438df2408ed88a5bec3a9a4b5f2afb0d3aec41c4cc63b2f5eb810b3cb'
- '809ede70c932183889b2fa567b340fb82cce1ada76c7b0a0b9efb82b87c92fa0'
- 'd341df55eb474ea323d22653af8698af70fca08713490cb917ed6ecacb63c41a')
+ '809ede70c932183889b2fa567b340fb82cce1ada76c7b0a0b9efb82b87c92fa0')
package() {
install -Dm755 -t "$pkgdir/usr/bin" $_pkgname
- install -Dm644 "$_pkgname.toml" "$pkgdir/etc/$_pkgname/config.toml"
+ install -Dm644 $_pkgname-$pkgver.toml "$pkgdir/etc/$_pkgname/config.toml"
install -Dm644 -t "$pkgdir/usr/lib/systemd/system/" "$_pkgname.service"
install -Dm644 -t "$pkgdir/usr/lib/sysusers.d/" "$_pkgname.conf"
}
diff --git a/listmonk.toml b/listmonk.toml
deleted file mode 100644
index 9ad6cd994dd4..000000000000
--- a/listmonk.toml
+++ /dev/null
@@ -1,22 +0,0 @@
-[app]
-# Interface and port where the app will run its webserver.
-address = "localhost:9000"
-
-# BasicAuth authentication for the admin dashboard. This will eventually
-# be replaced with a better multi-user, role-based authentication system.
-# IMPORTANT: Leave both values empty to disable authentication on admin
-# only where an external authentication is already setup.
-admin_username = "listmonk"
-admin_password = "<your_password>"
-
-# Database.
-[db]
-host = "localhost"
-port = 5432
-user = "listmonk"
-password = "listmonk"
-database = "<your_password>"
-ssl_mode = "disable"
-max_open = 25
-max_idle = 25
-max_lifetime = "300s"