summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Gahan2015-06-29 02:38:16 -0400
committerChris Gahan2015-06-29 02:40:09 -0400
commit4a43252f09b5b54adc4182e8d36d60e24f6986b6 (patch)
treeddfe7a73d925c223bf1bf882ff1661f8bbd94449
downloadaur-4a43252f09b5b54adc4182e8d36d60e24f6986b6.tar.gz
0.10.2.2 Update
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD52
2 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed16e0691817
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+# Generated by makepkg 4.2.1
+# Sun Jun 28 05:42:41 UTC 2015
+pkgbase = litecoin-bin
+ pkgdesc = Peer-to-peer digital currency, official binary release (includes litecoin-qt and litecoind)
+ pkgver = 0.10.2.2
+ pkgrel = 1
+ url = http://www.litecoin.org/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = bzip2
+ depends = expat
+ depends = fontconfig
+ depends = freetype2
+ depends = glib2
+ depends = libffi
+ depends = libice
+ depends = libpng
+ depends = libsm
+ depends = libx11
+ depends = libxau
+ depends = libxcb
+ depends = libxdmcp
+ depends = libxext
+ depends = libxrender
+ depends = openssl
+ depends = pcre
+ depends = qt4
+ depends = util-linux
+ depends = zlib
+ options = !strip
+ source = https://download.litecoin.org/litecoin-0.10.2.2/linux/litecoin-0.10.2.2-linux64.tar.gz
+ sha256sums = 136779e717603002f0a3f0da4f48f38274a286171cff10dd68da067ed82c8b26
+
+pkgname = litecoin-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02957699cc2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+pkgname=litecoin-bin
+pkgver=0.10.2.2
+pkgrel=1
+arch=('i686' 'x86_64')
+url="http://www.litecoin.org/"
+license=('MIT')
+pkgdesc="Peer-to-peer digital currency, official binary release (includes litecoin-qt and litecoind)"
+
+if [ ${CARCH} == 'x86_64' ]; then
+ _bits=64
+ sha256sums=(136779e717603002f0a3f0da4f48f38274a286171cff10dd68da067ed82c8b26)
+else
+ _bits=32
+ sha256sums=(eecffd46d3115013b7007d59762eaf819d4ac905ad53edffe164c20d779dfc40)
+fi
+source=(https://download.litecoin.org/litecoin-$pkgver/linux/litecoin-$pkgver-linux$_bits.tar.gz)
+
+options=('!strip')
+depends=(
+ bzip2
+ expat
+ fontconfig
+ freetype2
+ glib2
+ libffi
+ libice
+ libpng
+ libsm
+ libx11
+ libxau
+ libxcb
+ libxdmcp
+ libxext
+ libxrender
+ openssl
+ pcre
+ qt4
+ util-linux
+ zlib
+)
+
+package() {
+ cd "$srcdir/litecoin-$pkgver/bin"
+
+ mkdir -p "$pkgdir/opt/$pkgname"
+ cp * "$pkgdir/opt/$pkgname"
+ # chmod -R 755 "$pkgdir/opt/$pkgname"
+
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "/opt/$pkgname/litecoin-qt" "$pkgdir/usr/bin"
+ ln -s "/opt/$pkgname/litecoind" "$pkgdir/usr/bin"
+}