summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLoïc Guitaut2015-06-28 23:32:11 +0200
committerLoïc Guitaut2015-06-28 23:32:11 +0200
commitb718f09f1863d87be205693c3412ee22ebea6f10 (patch)
tree5219ec8a0b90fb73bdcdc29204ed940c55a5cedd
downloadaur-b718f09f1863d87be205693c3412ee22ebea6f10.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD38
-rw-r--r--litecoind@.service12
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0450d6046bd2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = litecoin-daemon
+ pkgdesc = Peer-to-peer network based digital currency (daemon)
+ pkgver = 0.8.7.5
+ pkgrel = 2
+ url = http://www.litecoin.org/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = boost
+ makedepends = automoc4
+ makedepends = qrencode
+ makedepends = miniupnpc
+ depends = boost-libs
+ depends = miniupnpc
+ depends = openssl
+ conflicts = litecoin
+ source = https://github.com/litecoin-project/litecoin/archive/v0.8.7.5.tar.gz
+ source = litecoind@.service
+ sha256sums = c1b04be2035c00f1af887c80c2d9c239acbb31ab581f734fe281741ace1c4539
+ sha256sums = 3e0afef47970cdf304a376b51dbbb44759ac7eeb232be1ea4b2b995817b5df88
+
+pkgname = litecoin-daemon
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ec365729502
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Loïc Guitaut <flink at belfalas dot eu>
+# Contributor: Lukas Sabota <lukas at lwsabota dot com>
+
+pkgname='litecoin-daemon'
+pkgver=0.8.7.5
+pkgrel=2
+arch=('i686' 'x86_64')
+url="http://www.litecoin.org/"
+makedepends=('boost' 'automoc4' 'qrencode' 'miniupnpc')
+license=('MIT')
+source=("https://github.com/litecoin-project/litecoin/archive/v$pkgver.tar.gz"
+ "litecoind@.service"
+)
+sha256sums=('c1b04be2035c00f1af887c80c2d9c239acbb31ab581f734fe281741ace1c4539'
+ '3e0afef47970cdf304a376b51dbbb44759ac7eeb232be1ea4b2b995817b5df88')
+pkgdesc="Peer-to-peer network based digital currency (daemon)"
+depends=(boost-libs miniupnpc openssl)
+conflicts=(litecoin)
+
+build() {
+ cd "$srcdir/litecoin-$pkgver"
+ CXXFLAGS="$CXXFLAGS -DBOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT=1"
+ make -f makefile.unix -C src CXXFLAGS="$CXXFLAGS" USE_UPNP=1
+}
+
+package() {
+ install -Dm644 litecoind@.service "$pkgdir/usr/lib/systemd/system/litecoind@.service"
+ cd "$srcdir/litecoin-$pkgver"
+ install -Dm755 src/litecoind "$pkgdir"/usr/bin/litecoind
+ install -Dm644 contrib/debian/examples/bitcoin.conf \
+ "$pkgdir/usr/share/doc/$pkgname/examples/litecoin.conf"
+ install -Dm644 contrib/debian/manpages/bitcoind.1 \
+ "$pkgdir"/usr/share/man/man1/litecoind.1
+ install -Dm644 contrib/debian/manpages/bitcoin.conf.5 \
+ "$pkgdir"/usr/share/man/man5/litecoin.conf.5
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
diff --git a/litecoind@.service b/litecoind@.service
new file mode 100644
index 000000000000..39c77f6820b0
--- /dev/null
+++ b/litecoind@.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=LiteCoin Daemon
+After=network.target
+
+[Service]
+User=%i
+Group=users
+Type=simple
+ExecStart=/usr/bin/litecoind
+
+[Install]
+WantedBy=multi-user.target