summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212021-10-30 11:33:07 +0200
committera8212021-10-30 11:33:07 +0200
commitd100cfdccc7bc6e0ff1998f2c7927760d5966ee9 (patch)
tree30c304445f09076a72b46d2ad836283155319a85
parent1af3276d87207deac9fa562809a7140ad4581837 (diff)
downloadaur-d100cfdccc7bc6e0ff1998f2c7927760d5966ee9.tar.gz
Version 0.18.1
Rewrote the whole PKGBUILD from scratch because a past maintainer had the /brillant/ idea to erase everything and made a -bin package (it used to build from sources). Important: The PKGBUILD builds litecoind and litecoin-cli as intended, but whether the dependency on Berkely DB 4.8 is necessary is unclear to me: I only tested that the package builds without errors.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
2 files changed, 33 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9823d25c39f..fcf6a4410baf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = litecoin-daemon
- pkgdesc = Peer-to-peer digital currency, official binary release for servers (includes litecoind and litecoin-cli)
- pkgver = 0.17.1
+ pkgdesc = Peer-to-peer digital currency (includes litecoind and litecoin-cli)
+ pkgver = 0.18.1
pkgrel = 1
- url = http://www.litecoin.org/
- arch = i686
+ url = https://www.litecoin.org/
arch = x86_64
license = MIT
+ makedepends = boost
depends = openssl
- options = !strip
- source_i686 = https://download.litecoin.org/litecoin-0.17.1/linux/litecoin-0.17.1-i686-pc-linux-gnu.tar.gz
- md5sums_i686 = 9e28e4d172821d485423acbd05655b57
- source_x86_64 = https://download.litecoin.org/litecoin-0.17.1/linux/litecoin-0.17.1-x86_64-linux-gnu.tar.gz
- md5sums_x86_64 = a152828cd984c4dda16719aa406609ff
+ depends = boost-libs
+ depends = libevent
+ depends = miniupnpc
+ depends = zeromq
+ depends = db4.8
+ source = litecoin-daemon-0.18.1.tar.gz::https://github.com/litecoin-project/litecoin/archive/refs/tags/v0.18.1.tar.gz
+ sha256sums = 2d67cba11adc5890b9698ccddeb68dd3c2ff6af19bf3ed0f1c719348b914042f
pkgname = litecoin-daemon
-
diff --git a/PKGBUILD b/PKGBUILD
index 32d3e89f1a59..43797daedd28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
# Maintainer:
-# Contributor: Felix Golatofski <contact@xdfr.de>
+
pkgname=litecoin-daemon
-pkgver=0.17.1
+pkgver=0.18.1
pkgrel=1
-arch=('i686' 'x86_64')
-url="http://www.litecoin.org/"
+arch=('x86_64')
+url="https://www.litecoin.org/"
license=('MIT')
-pkgdesc="Peer-to-peer digital currency, official binary release for servers (includes litecoind and litecoin-cli)"
-options=('!strip')
-depends=('openssl')
-source_x86_64=("https://download.litecoin.org/litecoin-$pkgver/linux/litecoin-$pkgver-x86_64-linux-gnu.tar.gz")
-source_i686=("https://download.litecoin.org/litecoin-$pkgver/linux/litecoin-$pkgver-i686-pc-linux-gnu.tar.gz")
-md5sums_i686=('9e28e4d172821d485423acbd05655b57')
-md5sums_x86_64=('a152828cd984c4dda16719aa406609ff')
+pkgdesc="Peer-to-peer digital currency (includes litecoind and litecoin-cli)"
+depends=('openssl' 'boost-libs' 'libevent' 'miniupnpc' 'zeromq' 'db4.8')
+makedepends=('boost')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/litecoin-project/litecoin/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('2d67cba11adc5890b9698ccddeb68dd3c2ff6af19bf3ed0f1c719348b914042f')
+build() {
+ cd litecoin-${pkgver}
+ ./autogen.sh
+ ./configure --prefix=/usr --without-gui
+ make
+}
package() {
- cd "$srcdir/litecoin-$pkgver/bin"
-
- destdir="$pkgdir/opt/$pkgname"
-
- mkdir -p "$destdir"
- cp * "$destdir"
-
- mkdir -p "$pkgdir/usr/bin"
- ln -s "/opt/$pkgname/litecoin-cli" "$pkgdir/usr/bin"
- ln -s "/opt/$pkgname/litecoind" "$pkgdir/usr/bin"
+ cd litecoin-${pkgver}
+ # make DESTDIR="${pkgdir}" install # for standard install
+ install -Dm755 -t "$pkgdir/usr/bin" src/litecoin{d,-cli}
+ install -Dm644 -t "$pkgdir/usr/share/man/man1" doc/man/litecoin{d,-cli}.1
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
+
+# vim: set ts=4 sw=4 et: