summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsurefire2020-06-05 08:53:05 +0300
committersurefire2020-06-05 08:53:05 +0300
commit82d7c5daa3f184d33c3058b48a83d91c0703c393 (patch)
tree41819ab3600b7c9b422705c2da6a30152e58bbd8
parent199f9f65cdbc4f689c6c57489f7b16a7bafd7345 (diff)
downloadaur-82d7c5daa3f184d33c3058b48a83d91c0703c393.tar.gz
upgpkg: litecoin-git 0.18.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
-rw-r--r--qt515.patch12
3 files changed, 29 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbed26814a1a..f6feaf548ceb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,9 @@
pkgbase = litecoin-git
- pkgver = 0.17.1+0+g1b6c48075
+ pkgver = 0.18.1+0+g81c4f2d80
pkgrel = 1
url = http://www.litecoin.org/
arch = x86_64
license = MIT
- makedepends = autoconf
- makedepends = automake
makedepends = boost
makedepends = git
makedepends = libevent
@@ -15,11 +13,13 @@ pkgbase = litecoin-git
makedepends = qt5-base
makedepends = qt5-tools
makedepends = zeromq
- source = litecoin-git::git+https://github.com/litecoin-project/litecoin.git#branch=0.17
+ source = litecoin-git::git+https://github.com/litecoin-project/litecoin.git#branch=0.18
+ source = qt515.patch
source = litecoin-qt.desktop
source = litecoind.service
source = litecoin.sysusers
sha256sums = SKIP
+ sha256sums = 97fbaf4f5dca82771a960b545c277a84eadce1eb146e8a61b0a31e73d2df6cc8
sha256sums = ec2a2669a50fa96147a1d04cacf1cbc3d63238aee97e3b0df3c6f753080dae96
sha256sums = 98f5a1b28fe13b9093fa89cfe56bb84af09ff5f0d6e9ca196ec02d6dd826ca88
sha256sums = a722b958a7e9b3468d902efa6c9804e01d78fdf88ead4252c934aee2b1d800db
diff --git a/PKGBUILD b/PKGBUILD
index 52ebc20fc803..9b28faf22d23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,13 @@
pkgbase=litecoin-git
pkgname=('litecoin-daemon-git' 'litecoin-cli-git' 'litecoin-qt-git' 'litecoin-tx-git')
-pkgver=0.17.1+0+g1b6c48075
+git_branch=0.18
+pkgver=0.18.1+0+g81c4f2d80
pkgrel=1
arch=('x86_64')
url="http://www.litecoin.org/"
license=('MIT')
makedepends=(
- 'autoconf'
- 'automake'
'boost'
'git'
'libevent'
@@ -22,16 +21,26 @@ makedepends=(
'zeromq'
)
source=(
- "$pkgbase::git+https://github.com/litecoin-project/litecoin.git#branch=0.17"
+ "$pkgbase::git+https://github.com/litecoin-project/litecoin.git#branch=$git_branch"
+ "qt515.patch"
'litecoin-qt.desktop'
'litecoind.service'
'litecoin.sysusers'
)
sha256sums=('SKIP'
+ '97fbaf4f5dca82771a960b545c277a84eadce1eb146e8a61b0a31e73d2df6cc8'
'ec2a2669a50fa96147a1d04cacf1cbc3d63238aee97e3b0df3c6f753080dae96'
'98f5a1b28fe13b9093fa89cfe56bb84af09ff5f0d6e9ca196ec02d6dd826ca88'
'a722b958a7e9b3468d902efa6c9804e01d78fdf88ead4252c934aee2b1d800db')
+
+prepare() {
+ cd "$pkgbase"
+ autoreconf -fi
+
+ patch -Np1 -i ../qt515.patch
+}
+
pkgver() {
cd "$pkgbase"
git describe --long --tags | sed 's/-/+/g; s/^v//'
@@ -39,7 +48,6 @@ pkgver() {
build() {
cd "$pkgbase"
- ./autogen.sh
./configure --prefix=/usr --with-gui=qt5 --with-incompatible-bdb --disable-gui-tests
make
}
diff --git a/qt515.patch b/qt515.patch
new file mode 100644
index 000000000000..6fe317fc8e1f
--- /dev/null
+++ b/qt515.patch
@@ -0,0 +1,12 @@
+diff --git a/src/qt/trafficgraphwidget.cpp b/src/qt/trafficgraphwidget.cpp
+index 1588be8da..b0091ada3 100644
+--- a/src/qt/trafficgraphwidget.cpp
++++ b/src/qt/trafficgraphwidget.cpp
+@@ -7,6 +7,7 @@
+ #include <qt/clientmodel.h>
+
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QColor>
+ #include <QTimer>
+